TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\folder-display\test-deletion-from-virtual-folders.js - TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\folder-display\test-deletion-with-multiple-displays.js

RESOLVED FIXED in Thunderbird 54.0

Status

Thunderbird
General
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Jorg K (GMT+1), Unassigned)

Tracking

({intermittent-failure})

unspecified
Thunderbird 54.0
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\folder-display\test-deletion-from-virtual-folders.js | test-deletion-from-virtual-folders.js::test_delete_last_message_from_smart_inbox_closes_message_displays
TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\folder-display\test-deletion-with-multiple-displays.js | test-deletion-with-multiple-displays.js::test_delete_last_message_closes_message_displays

This is now seen frequently on C-C and C-A. It started on C-C after landing
https://hg.mozilla.org/comm-central/rev/27e021adf35e5b68d36a1ff9d2122070e8a6bebe
in bug 1334874.

It also started on C-A and C-B after the uplift of bug 1334874.

BTW, that change has also caused bug 1340517. So I have to back this out from C-B for TB 52 beta 4 and I'm inclined to back it out altogether.

Kent, can you enlighten us?
Flags: needinfo?(rkent)
Flags: needinfo?(aleth)
(Reporter)

Comment 1

a year ago
I've since backed out
https://hg.mozilla.org/comm-central/rev/27e021adf35e5b68d36a1ff9d2122070e8a6bebe
from all branches. Let's see whether that makes the failure disappear.
(Reporter)

Comment 2

a year ago
Since the backout, this wasn't seen any more.
(Reporter)

Comment 3

a year ago
Not seen any more, so closing this.

We also understand what happened, quoting Kent from IRC:
That patch was meant more as a demo of getting a weak JS reference. Regressions are caused (generally) when the weak reference fails because nobody is holding onto the parent, and it gets GC'd.

So intermittently some object got garbage-collected and the test failed, and other times it didn't.

Resolved Fixed by backout in bug 1334874.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(rkent)
Flags: needinfo?(aleth)
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 54.0
You need to log in before you can comment on or make changes to this bug.