[FLOAT]Kellys Blue Book - Layout rearranges upon printing

VERIFIED FIXED in mozilla1.2alpha



Printing: Output
16 years ago
4 years ago


(Reporter: Susie Wyshak, Assigned: karnaze (gone))


({embed, top100, topembed-})

Windows 2000
embed, top100, topembed-
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [adt2], URL)


(1 attachment)



16 years ago
"Blue Book Private Party Report" moves all main content below the navigation on
the printed page...the purpose of this page is as a report so it is not good. It
looks fine on the screen. Prints fine in IE.

To replicate:
1. go to http://www.kbb.com
2. click "My Car's Value"
3. Pick a year
4. Pick models then fill out form, and submit
5. print the report

Browsers: Win2K, 9.4 builds and Gecko/20020314
   -->Prints as expected in IE 6 

Printer: Only tested on Laserjet 5Si MX

Replicatability: always

Comment 1

16 years ago
Created attachment 76672 [details]
Source code for page that printed wrong

Comment 2

16 years ago
marked topembed, nsbeta 1
KBB is #133 in Media Metrix ranking.
Keywords: nsbeta1, topembed

Comment 3

16 years ago
*** Bug 134093 has been marked as a duplicate of this bug. ***
added top100 keyword. set severity to major. Critical is reserved for crashers
and hangs
Severity: critical → major
Keywords: top100

Comment 5

16 years ago
Looks like a table printing bug to me
Assignee: rods → karnaze
Keywords: nsbeta1, topembed → nsbeta1+, topembed-
Target Milestone: --- → mozilla1.0

Comment 7

16 years ago
I tried it a few times and couldn't proceed as the description says. First, I 
had to select either trade-in or private-party. Then when I finally got to the 
form and submitted it, it said:

 We were unable to complete the processing of your request because:

Please click the "Back" button and re-submit the form with the missing or 
corrected information.

It was trying to tell me that I had forgotten to fill in something, but it 
didn't mention what it was, and I really did fill everything in. 

Any suggestions?

Comment 8

16 years ago
I was able to get the form after more attempts and changing the vehicle. The 
form has at least one floater in it which may explain why the print layout is so 
Keywords: qawanted

Comment 9

16 years ago

@media print {
  /* undo floats on aligned tables since we cannot print them correctly: see bug
74738 and bug 85768 */
  table[align="left"] {
    float: none;

  table[align="right"] {
    float: none;

Comment 10

16 years ago
Alex, we can't just remove that, because it will break other things. We need to 
fix floaters "once and for all" to print correctly. Over to you.  
Assignee: karnaze → alexsavulov

Comment 11

16 years ago
i know, i know :-)
Summary: Kellys Blue Book - Layout rearranges upon printing → [FLOAT]Kellys Blue Book - Layout rearranges upon printing


16 years ago
Keywords: embed
Whiteboard: [adt2]

Comment 12

16 years ago
Taking the bug back, since I am going to look at the problem of 
printing/splitting floaters. This surely won't make the m1.0 branch.
Assignee: alexsavulov → karnaze
Priority: -- → P2
Target Milestone: mozilla1.0 → mozilla1.0.1
Marking nsbeta1-. This will require a large change.
Keywords: nsbeta1+ → nsbeta1-

Comment 14

16 years ago
bug 145305 probably fixed this.
Last Resolved: 16 years ago
Resolution: --- → FIXED


16 years ago
Depends on: 145305
nsbeta1+. For next release.
Keywords: nsbeta1- → nsbeta1+
Target Milestone: mozilla1.0.1 → mozilla1.2alpha


16 years ago
Blocks: 176349

Comment 16

15 years ago
Updating qa contact to sairuh@netscape.com
QA Contact: sujay → sairuh
looks fine with 2003.06.09.05-1.4 comm build on win2k.
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.