Closed Bug 1341381 Opened 3 years ago Closed 3 years ago

Intermittent PROCESS-CRASH | devtools/client/performance/test/browser_perf-details-render-01-js-calltree.js | application crashed [@ TimerThread::Run()] after Assertion failure: rc != 0 (destroyed timer off its target thread!), at TimerThread.cpp:505

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1334383

People

(Reporter: aryx, Unassigned)

References

Details

(Keywords: assertion, intermittent-failure)

https://treeherder.mozilla.org/logviewer.html#?job_id=79119804&repo=mozilla-inbound

Assertion failure: rc != 0 (destroyed timer off its target thread!), at c:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/src/xpcom/threads/TimerThread.cpp:505
09:48:01     INFO - #01: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:1265]
09:48:01     INFO - 
09:48:01     INFO - #02: NS_ProcessNextEvent(nsIThread *,bool) [xpcom/threads/nsThreadUtils.cpp:389]
09:48:01     INFO - 
09:48:01     INFO - #03: mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:338]
09:48:01     INFO - 
09:48:01     INFO - #04: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:238]
09:48:01     INFO - 
09:48:01     INFO - #05: MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:232]
09:48:01     INFO - 
09:48:01     INFO - #06: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:212]
09:48:01     INFO - 
09:48:01     INFO - #07: nsThread::ThreadFunc(void *) [xpcom/threads/nsThread.cpp:497]
09:48:01     INFO - 
09:48:01     INFO - #08: _PR_NativeRunThread [nsprpub/pr/src/threads/combined/pruthr.c:397]
09:48:01     INFO - 
09:48:01     INFO - #09: pr_root [nsprpub/pr/src/md/windows/w95thred.c:95]
09:48:01     INFO - 
09:48:01     INFO - #10: ucrtbase.DLL + 0x3d5ef
09:48:01     INFO - 
09:48:01     INFO - #11: kernel32.dll + 0x53c45
09:48:01     INFO - 
09:48:01     INFO - #12: ntdll.dll + 0x637f5
09:48:01     INFO - 
09:48:01     INFO - #13: ntdll.dll + 0x637c8
09:48:01     INFO - 
09:48:01     INFO - TEST-INFO | Main app process: exit 1
09:48:01    ERROR - TEST-UNEXPECTED-FAIL | ShutdownLeaks | process() called before end of test suite
Priority: -- → P3
See Also: → 1349768
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334383
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.