Closed Bug 1343930 Opened 5 years ago Closed 5 years ago

Headset plugging/unplugging results in tab crash when the play button is pressed

Categories

(Core :: Audio/Video: cubeb, defect, P1)

All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla55
Tracking Status
firefox-esr45 --- unaffected
firefox51 --- unaffected
firefox52 --- wontfix
firefox-esr52 --- verified
firefox53 --- verified
firefox54 --- verified
firefox55 --- verified

People

(Reporter: emilghitta, Assigned: achronop)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

[Note]
This is a follow up bug for -- Bug 1343920

[Affected versions]:
Firefox 52.0b2 (Build Id:20170130065342)
Firefox 52.0b9 (Build Id:20170223185858)
Firefox 54.0a1 (Build Id:20170302030206)
Firefox old Nightly 52.0a1 (Build Id:20161022030204)


[Steps to reproduce]:
1.Launch Firefox.
2.Access the https://www.youtube.com/watch?v=gjQmTkMjIBg weblink (or any YouTube video).
3.Press the pause button.
4.Unplug headphones.
5.Plug headphones.
6.Click on the Play button
7.Observe that the tab crashes

[Expected result]:
The video continues to play.

[Actual result]:
The tab crashes if the headphones are unplugged, plugged again and then the play button is pressed.

[Regression range]:
This is an old regression:
The latest good build is old Nightly from 2016-10-21
The first bad build is old Nightly from 2016-10-22
Pushlog:https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f0f1aaf051d6798e1e73d1feee07ca847333167a&tochange=5639a9f476d08f300c079117e61697f5026b6367

Also, please note that I didn’t succeed in reproducing this issue on 
Firefox 52 beta 1. This issue is reproducible from Firefox 52 beta 2 onward. 
Pushlog:
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=78ae21055d9f&tochange=0f339c1e154f

[Additional information]:
Please Note that the web browser might crash by following this steps several times.
I have attached a Crash Signature which was reproduced only once by following the up mentioned steps (bp-b263058b-1b03-462c-bca2-ffb322170227)

This issue is reproducible using headphones that are connected via jack or USB.

This issue is not reproducible on Windows and Linux.

This issue is not reproducible on Firefox 52.0b1 (Build Id:20170124094647), Firefox ESR 52.0 (Build Id:20170227085837) and Firefox old Nightly from 2016-10-21.
Keywords: regression
Are you sure this is the right crash report? This crash should only happen when you're shutting down the browser, which is not part of your STR.
Flags: needinfo?(emil.ghitta)
Can you check about:crashes for other reports?
This uplifted to beta between b1 and b2:

	dc169ee114d4	Paul Adenot — Bug 1331869 - Uplift the OSX portion of bug 1331869 to beta. r=achonop, a=jcristau
and that's osx-only, which (apparently) this bug is (emil, can you confirm?)

padenot: can you check this asap?
Flags: needinfo?(padenot)
Hi Benjamin!
The mentioned crash report was a random crash that I have encountered while testing this issue using the up mentioned steps (It only happened once). 
I have just retested this issue and it seems that now (by following the mentioned steps), Firefox crashed with this signature :
bp-03ff8b87-9574-4ca4-91c5-7dbc82170306,bp-9e92cd02-e74c-4753-bfad-3e5842170306 and bp-35ee6631-91a6-454a-973b-4b46a2170306.

Until now, this issue led only to a tab crash which was silent (it did not appeared in about:crashes).
Please note that I have further investigated this issue and found that the output is somehow random (The crash with the mentioned signature appeared several times but after retesting this issue with the same steps but on different clean profiles, the Tab crashed (silent crash).

If you have more questions, please let me know
Flags: needinfo?(emil.ghitta)
Hi Randell,
This issue is reproducible only on Mac OS.
The crash at [@ libsystem_kernel.dylib@0x15866 ] called from mozilla::AudioStream::Resume() is pretty clearly this bug, and probably happens immediately after resuming. The other crash here is an unrelated shutdown issue and shouldn't be happening immediately.
302 achronop, but I can help if needed.
Flags: needinfo?(padenot) → needinfo?(achronop)
Component: Audio/Video → Audio/Video: Playback
Component: Audio/Video: Playback → Audio/Video: cubeb
Flags: needinfo?(achronop)
Flags: needinfo?(achronop)
Rank: 15
Priority: -- → P1
I could not repro but I believe it is fixed by bug 1345049. I close for now and we can reopen if the problem remains.
Flags: needinfo?(achronop)
Depends on: 1345049
Alex have you asked the people who can reproduce to retest?
Flags: needinfo?(achronop)
Since I cannot repro, can you please retest with latest Nightly?
Flags: needinfo?(achronop) → needinfo?(emil.ghitta)
Duplicate of this bug: 1347067
Hi Alex!
This issue is not reproducible on the latest Firefox Nightly 55.0a1 (Build Id:20170314030215).
Flags: needinfo?(emil.ghitta)
Thanks Emil, I'll close the bug as fixed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → achronop
Target Milestone: --- → mozilla55
Duplicate of this bug: 1328147
Hi everyone! 

Please note that I have reproduced this issue using Firefox 52.0.2esr (Build Id:20170323110425) on Mac 10.12.1.
Flags: needinfo?(achronop)
Flags: needinfo?(achronop)
Landed to 55, 54, 53 with Bug 1345049
Hi everyone!

Please note that I have found a different behavior this time while retesting the issue, mentioned in comment 0, with Mac OS 10.11.6:

The media will no longer play if unplugging/plugging the headset a couple of times on the following builds:

Firefox 52.1.0esr (Build Id:20170410145022)
Firefox 53.0b10 (Build Id:20170407033734)

For further details regarding this behavior please access the following link https://drive.google.com/open?id=0B94iuIVMr-TEcktkZjdpc1dpSE0 in order to observe the video.

The new found issue is not reproducible on the following builds:

Firefox 54.0a2 (Build Id:20170410004019)
Firefox 55.0a1 (Build Id:20170410030221)


It is safe to say that the tab no longer crashes after unplugging/plugging the headsets.

Should I log a new issue with the recently found behavior?

Thanks!
I cannot repro in 53.0b9. Can you please retest with a clean profile. I would say it's better to open a new issue and discuss it there in details including the steps to repro. The problem is that 53 is going to Release next week so it's too late to uplift anything there. The good point is that it does not sound like a very common scenario so we may can live with it.
You need to log in before you can comment on or make changes to this bug.