Closed Bug 1344390 Opened 7 years ago Closed 5 years ago

Suggestions from password manager stay on screen and then disappear forever when closing tab with browser.tabs.animate=false

Categories

(Toolkit :: Password Manager, defect)

52 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox51 --- unaffected
firefox52 --- wontfix
firefox53 --- wontfix
firefox54 --- fix-optional
firefox55 --- ?
firefox56 --- ?

People

(Reporter: 684sigma, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

I have a problem with Firefox Beta 52. It doesn't happen in Firefox Release 51.
Sometimes notification "Logins entered here could be compromised" stays when I close tab and never appears again.
It happens unpredictably, however, I noticed one specific scenario when it happens

(sorry, I don't want you to know exact sites I visit, but it this scenario should work)

1. Open http://example.com in a new tab and execute the following line in web console:
document.body.innerHTML=`<form method="post" action="/"><input name="L"><input name="P" type="password" size="12">`; document.querySelector("[name='P']").focus();
2. Close web console => input will be focused automatically and display the notification
3. Close tab by pressing Ctrl+W to close tab

Result: notification stays on screen. After that, the notification never appears again, at least for me
Expected: notification should go away. After that, the notification should always appear when it should
Strange, the issue doesn't happen in new profile, but does happen in safe mode on old profile. I'll post an update.
Alright, this happens on new profile if pref "browser.tabs.animate" is set to "false". That pref is part of my default install.

Regardless from the described bug, I would appreciate any advice on removing the notification forever, because it seems annoying.
Yes, it's reproducible, in FF52 and FF54.


MattN, any thoughts about this issue?
Status: UNCONFIRMED → NEW
Component: Untriaged → Security
Ever confirmed: true
Flags: needinfo?(MattN+bmo)
Summary: Regression Notification "Logins entered here could be compromised" stays when I close tab and never appears again sometimes → Notification "Logins entered here could be compromised" stays on screen when closing tab with browser.tabs.animate=false
Blocks: 1304224
This also happens with suggestions from login fields on secure (https://) sites
Component: Security → Password Manager
Keywords: regression
Product: Firefox → Toolkit
Too late for firefox 52, mass-wontfix.
Too late for a fix for 53, minor carryover regression, no one assigned, so these don't seem like a high priority.
Suggestions from password manager disappear until restart, how it this "minor" ?
Summary: Notification "Logins entered here could be compromised" stays on screen when closing tab with browser.tabs.animate=false → Suggestions from password manager stay on screen and then disappear forever when closing tab with browser.tabs.animate=false
See Also: → 1335332
See Also: → 1329333
Hello 684signma,

I can't reproduce the problem by following comment 0 + comment 2 on 56.0a1 (2017-07-18) (64-bit) OS X. Can you confirm that it's also fixed for you?
Flags: needinfo?(MattN+bmo) → needinfo?(684sigma)

I can no longer reproduce this with the replacement pref set (toolkit.cosmeticAnimations.enabled=false). I tested with the autocomplete popup from http://http-password.badssl.com/ open.

Yang, can you still reproduce?

Flags: needinfo?(yfdyh000)

I may not have reproduced it before.

Flags: needinfo?(yfdyh000)

OK, marking as WORKS FOR ME for now but re-open if anyone can reproduce this.

Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(684sigma)
You need to log in before you can comment on or make changes to this bug.