Browser: Basic Authentication will not open auth. dialog (eventually error message instead) under particular Email Window related conditions

RESOLVED FIXED in seamonkey2.54

Status

SeaMonkey
General
--
major
RESOLVED FIXED
5 months ago
6 days ago

People

(Reporter: Nasr, Unassigned)

Tracking

({regression, reproducible})

SeaMonkey 2.48 Branch
seamonkey2.54
Unspecified
All
regression, reproducible
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.48 wontfix, seamonkey2.49esr fixed, seamonkey2.50 wontfix, seamonkey2.51 wontfix, seamonkey2.52 wontfix, seamonkey2.53 wontfix, seamonkey2.54 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
Created attachment 8848010 [details]
Capture11.PNG

Comment 1

5 months ago
@Reporter: Thank you for your attention. But unfortunately I haven't a clue what you want to tell. That Autofill for authentication fields does not work?

Please:
a) Contribute a problem related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem due to 
   <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
   (similar to report in Bug 1139273)
c) add information 
c1) concerning your Operating System (Version, Distribution, Language)
c3) SM settings that might be related to your problems 
    May be you should attach a copy of menu 
   'Help → Trouble shooting information”' as a text document
c5) Whether problem persists in Safe Mode without add-ons
c6) Whether problem persists with blank new profile
Flags: needinfo?(nasr1404)

Comment 2

5 months ago
This <https://seamonkeyde.wordpress.com/2017/03/14/neue-inoffizielle-lokalisierte-seamonkey-2-49-release-builds-verfuegbar/comment-page-1/#comment-511> one?

@reporter:
a): Is your problem related to open Email Client?
I doubt you will get a response.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(nasr1404)
Resolution: --- → DUPLICATE
Duplicate of bug: 1347855

Comment 4

5 months ago
(In reply to Frank-Rainer Grahl from comment #3)
> I doubt ...

Me too, but I was able to reproduce the bug (see comment 2). Unfortunately I haven't yet found a method to make the bug reproducible reliably, currently I'm even not able to reproduce the bug. I'm still working on this issue.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 5

5 months ago
Steps how to reproduce  NOT reproducible REPRODUCIBLE with Installation of  official  en-US SeaMonkey 2.51a1 (NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0 Build 20170207004355  (Default Classic Theme) on German WIN7 64bit

(paraphrased translation from http://shortlinks.de/54ng):
10. In Browser open this Bug so that it is in History → Quit SeaMonkey
11. Open Browser by double click on SeaMonkey-Desktop-Icon → Open
    Email client via menu ˋWindow → Emailˊ → Back to Browser via Window-menu
    → Close Browser Window with “Close-X” → From Email client via menu ˋWindow
    → Browserˊ open new Browser window
12. Open this Bug with click on History entry in History Sidebar Panel
13. Click left button “Standard Auth”
» Error message instead of 2 lines authentication dialog will open

a): STR currently work reliably for me to reproduce the issue
Status: REOPENED → UNCONFIRMED
status-seamonkey2.51: --- → affected
Component: Composer → General
Ever confirmed: false
Keywords: reproducible
OS: Windows 8.1 → Windows
Hardware: x86_64 → Unspecified
Summary: blank login not displaying error → Browser: Basic Authentication will not open auth. dialog (eventually error message instead) under particular Email Window related conditions

Comment 6

5 months ago
Corrected Steps:
10. In Browser open this Bug so that it is in History → Quit SeaMonkey
11. Open Browser by double click on SeaMonkey-Desktop-Icon → Open
    Email client via menu ˋWindow → Emailˊ → Back to Browser via Window-menu
    → Close Browser Window with “Close-X” → From Email client via menu ˋWindow
    → Browserˊ open new Browser window
12. Open this Bug with click on History entry in History Sidebar Panel → open
    <https://auth-demo.aerobatic.io/>
13. Click left light blue button “Standard Auth”
» Error message instead of 2 lines authentication dialog will open

Comment 7

5 months ago
e) Seems to be a 2.48 regression:
e1)Already REPRODUCIBLE with:
   2.48 Build-Identifikator: 20170204204049 (By FRG)
   2.48 Build-Identifikator: 20161201160950

e2) Was still ok with:
   2.47 Build identifier: 20170108194452 (By FRG)	
   2.46 Build-Identifikator: 20161213183751
   2.40 Build identifier: 20160120202951
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 months ago
Keywords: regression
Version: SeaMonkey 2.51 Branch → SeaMonkey 2.48 Branch

Comment 8

5 months ago
REPRODUCIBLE with Server-Installation of  official  en-US SeaMonkey 2.50a1 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0 Build 20170118003001  (Default Classic Theme) on VirtualBox Ubuntu 14.04.1
OS: Windows → All
Autocomplete was heavily refactored for 2.48 / Gecko 51. SeaMonkey also switched to the Mozilla autocomplete bindings in Bug 1300547. Probably fallout from the refactoring in the mozilla tree.

Workaround to get over the error just close the mail window and reopen it.

>> Timestamp: 3/19/17, 1:56:47 PM
>> Error: TypeError: win.gBrowser is undefined
>> Source File: resource://gre/components/nsLoginManagerPrompter.js
>> Line: 1426
See Also: → bug 1367191
Depends on: 1350152
Duplicate of this bug: 1377798
status-seamonkey2.48: --- → wontfix
status-seamonkey2.49esr: --- → affected
status-seamonkey2.50: --- → wontfix
status-seamonkey2.51: affected → wontfix
status-seamonkey2.52: --- → affected
status-seamonkey2.53: --- → affected
Duplicate of this bug: 1387367
Depends on: 1388166
Fixed by bug 1388166 and bug 1350152. 

The required fixes are now in the TB mozilla-esr52 release branch which we will use for building 2.49.1 

There are currently no plans for a 2.53 beta so wontfix here.
Status: NEW → RESOLVED
Last Resolved: 5 months ago8 days ago
status-seamonkey2.49esr: affected → fixed
status-seamonkey2.52: affected → wontfix
status-seamonkey2.53: affected → wontfix
status-seamonkey2.54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.54
https://hg.mozilla.org/releases/mozilla-esr52/rev/f822bda79c28da0ad93b67d46abcb66f6d5c8c92
You need to log in before you can comment on or make changes to this bug.