[LAYER] Contents of NOLAYER are not displayed.

VERIFIED FIXED

Status

defect
P2
major
VERIFIED FIXED
20 years ago
4 years ago

People

(Reporter: dsuljoti, Assigned: bc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

It seems like the new browser does not support the layer/ilayer tags.

However content that is wrapped inside <nolayer> tags is not shown either. Should't this be eliminated. The content within the nolayer tag should be displayed in this case.
Assignee: chofmann → ekrock
over to ekrock to mark dup
Status: NEW → ASSIGNED
Assignee: ekrock → troy
Status: ASSIGNED → NEW
Summary: layer tag not supported, but nolayer is. → Contents of NOLAYER are not displayed.
Per our conversation earlier, Nav5 will ignore the LAYER/ILAYER tags but display
their contents (if any) as well as the contents of any NOLAYER tag.  Troy, if
you haven't filed a bug against yourself already to make that parser change to
pass through contents of NOLAYER, you can use this.
Assignee: troy → rickg
Why would I be making parser changes?

Rick, are you going to be making this change?
Assignee: rickg → harishd
Harish -- one for you.
Blocks: 17907
Target Milestone: M12
It is urgent that we fix this bug ASAP (probably immediately post-dogfood)
because: (1) we are asking external content/web app developers to modify their
content to support Nav5, and (2) those who use <LAYER
...><NOLAYER>...</NOLAYER></LAYER> markup as a cross-browser support technique
are blocked on doing their upgrades until we fix this.  We don't want to block
the people who are trying to support us. ;->
Whiteboard: [TESTCASE]
On further investigation, I think this bug is INVALID. Open
http://sites.netscape.net/ekrock/tests/layer-then-nolayer.html in Mozilla.
(I used 1999113012 of Commercial on WinNT 4.0 SP3.) Contents of NOLAYER *are*
displayed in Mozilla as expected.
Whiteboard: [TESTCASE]
OK, there seems to be a problem here.  Before, I was unable to contact the
server for the original page http://www.demoserver.com/drit/think.html. Now when
I display it and view source, it appears that there *is* content that we'd
expect to be displayed:

<IFRAME SRC="http://ad.doubleclick.net/adi/drit.support.net/;thnk=unum3"
MARGINWIDTH=0 MARGINHEIGH=0 WIDTH=468 HEIGHT=60 HSPACE=0 VSPACE=0 FRAMEBORDER=0
SCROLLING="no">
<A
HREF="http://ad.doubleclick.net/jump/northernlight.com/results;kw=clinton;ord=90
5449316">
<IMG
SRC="http://ad.doubleclick.net/ad/northernlight.com/results;kw=clinton;ord=90544
9316" WIDTH=468 HEIGHT=60 ALT="please visit our sponsor" border=0></A>
</iframe>


<P>&nbsp;
<P>&nbsp;

<nolayer>
<IFRAME SRC="http://ad.doubleclick.net/adi/drit.support.net/;thnk=unum3"
MARGINWIDTH=0 MARGINHEIGH=0 WIDTH=468 HEIGHT=60 HSPACE=0 VSPACE=0 FRAMEBORDER=0
SCROLLING="no">
<A
HREF="http://ad.doubleclick.net/jump/northernlight.com/results;kw=clinton;ord=90
5449316">
<IMG
SRC="http://ad.doubleclick.net/ad/northernlight.com/results;kw=clinton;ord=90544
9316" WIDTH=468 HEIGHT=60 ALT="please visit our sponsor" border=0></A>
</iframe>
</nolayer>

... but we're not seeing it.  In fact, I see practically nothing for this page
on either Nav4.7 or 11/30 Nav5 Commercial.

There appears to be a problem, but it's nothing so simple as contents of NOLAYER
failing to display in all cases.  I've attached a test case showing that Nav5
*does* display the contents of an isolated NOLAYER. It's online here:
http://sites.netscape.net/ekrock/tests/layer-then-nolayer.html

dsuljoti, could you please try to create a simplified test case with the minimal
HTML markup and images necessary to reproduce the bug?
For a whole matrix of LAYER, ILAYER, NOLAYER, and IFRAME combinatorial test
cases, see http://sites.netscape.net/ekrock/tests/matrix.html
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Summary: Contents of NOLAYER are not displayed. → [LAYER] Contents of NOLAYER are not displayed.
Good news: I spoke by phone with dsuljoti. By comparing the behavior of M11 and
11/30 Commercial, we found that this bug occurred in M11 but no longer occurs in
11/30 Commercial.  Clearly, it was fixed between M11 and 11/30, so I'm closing
this bug out as INVALID.  Thanks to all!
Status: RESOLVED → VERIFIED
Marking Verified.
No longer blocks: 17907
Moving all [LAYER] bugs to Evangelism component for tracking and open-source
evangelism by mozilla community members of sites that need to upgrade to support 
web standards such as HTML 4.0 (instead of LAYER/ILAYER) and the W3C DOM
(instead of Nav4 document.layers[] or IE document.all()). Sites should be
lobbied to do the upgrade using the email templates that are linked to from
http://www.mozilla.org/newlayout/bugathon.html#layerbugs . When a site's owner
has confirmed receipt of the message requesting an upgrade, the bug should be
marked with the keyword evangelized to indicate that evangelism for that bug is
complete. When the site finishes the upgrade and supports standards, the bug
should be closed.
Assignee: harishd → nobody
Status: VERIFIED → NEW
Component: Tracking → Evangelism
Keywords: evangwanted
QA Contact: leger → nobody
Target Milestone: M13 → ---
Closing all Evangelism bugs where no evangelism is needed because page has been 
fixed, site is internal to Netscape, report is a DUP, or bug report is no longer 
appropriate for evangelism for any other reason.
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
SPAM:Changing QA contact on 111 evang bugs as I am now the new QA contact for 
this component.

Sorry about the spam

zach
QA Contact: nobody → zach
Reassigning Evangelism bugs to me, the component's new owner.  I would like to 
take this opportunity to thank nobody@mozilla.org for all of his dedication, 
contributions, and hard work, and wish him luck at his new job.  Thanks, nobody.
Assignee: nobody → BlakeR1234
Status: RESOLVED → NEW
workaround bugzilla problem that caused a bunch of evangelism bugs to be 
NEW/INVALID, NEW/FIXED, NEW/WORKSFORME or NEW/DUPLICATE
Resolution: INVALID → ---
Severity: normal → major
Status: NEW → ASSIGNED
OS: other → All
Priority: P3 → P2
Hardware: PC → All
Target Milestone: --- → mozilla0.6
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Status: ASSIGNED → NEW
Keywords: evangwanted
Target Milestone: mozilla0.6 → Future
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
Page no longer exists. Marking fixed.
Status: NEW → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → FIXED
Page exists, but problem is fixed. Verifying.
Status: RESOLVED → VERIFIED
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Target Milestone: Future → ---
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.