Block Playback feature is not working as intended on several websites

RESOLVED DUPLICATE of bug 1347758

Status

()

Core
Audio/Video: Playback
--
major
RESOLVED DUPLICATE of bug 1347758
a year ago
a year ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 unaffected, firefox53 unaffected, firefox54 affected, firefox55 affected)

Details

[Affected versions]:
- latest Developer Edition 54.0a2 (Build Id:20170321004022)
- latest Nightly 55.0a1 (Build Id:20170321030211)

[Affected platforms]:
- Ubuntu 14.04 32bit

[Steps to reproduce]:
1. Launch Firefox
2. Open the http://www.givemesport.com/
3. Open any autoplay video in an new tab from the website
4. Wait for the tab to load
5. Observe that the Play Tab button is not displayed and the video is playing and the audio is being outputted even if the opened tab was not focused

[Expected result]:
- After opening a video/audio in a new tab (without focusing the tab), the Play Tab button is displayed and the media is blocked.

[Actual result]:
- After opening a video/audio in a new tab (without focusing the tab), the Play tab button is not displayed and the media is working on the background.

[Regression range]:
- This is not a recent regression, it reproduces back to old Nightly from 2016-11-12 where the feature was first enabled by default in Nightly.

[Additional Information]:
- This is not an issue using Ubuntu 16.04 64bit, Windows 
- Please note that I have found the following behavior as well:
After accessing the bbc.com and opening a video with autoplay in a new tab, the Play Tab button is displayed but the media is not blocked (sound can be heard and the video is running in background). - Please let me know if this requires a new bug or not.
Flags: needinfo?(alwu)

Comment 1

a year ago
This issue can also be fixed by bug1347758.
But one thing worth be notice is that now we can't really PAUSE nsNPAPI because it didn't support that.

---

Hi, Baku,
Do you know whether we can add ability to pause nsNPAPI, like what we did for muting?
Thanks!
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(alwu) → needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1347758
We have retested this issue on Firefox latest Nightly and here are the following results:

Not working: Please note that the video is not paused and still plays in the background
Working: The sound is muted until the tab is focused and the Play Tab indicator is displayed.

We have retested this issue using the following platforms:
Ubuntu 14.04 32bit.


Alastor, could you take a look at the not working part?
Flags: needinfo?(alwu)

Comment 3

a year ago
See bug1350947, now we don't support "pause" for NPAPI.
Flags: needinfo?(amarchesini)
Flags: needinfo?(alwu)
I have retested this issue on Firefox latest Nightly 55.0a1 (Build Id:20170331030216)using Ubuntu 14.04 32bit and Ubuntu 14.04 64bit and I have noticed the following behavior:

Not Working: 
The sound is not muted and can be heard in the background.
The video is not paused and is playing in the background.
Flags: needinfo?(alwu)

Comment 5

a year ago
Same issue as bug1350947.

---

Could you describe the situation about the sound is not muted?
Do you have any reproduce steps? And does it only happen on Linux?
Thanks!
Flags: needinfo?(alwu) → needinfo?(emil.ghitta)

Comment 6

a year ago
Hi, Emil,
Which version do you use now?
If you're using the flash version under 25.0.0.127 (see bug1325592), the muting ability is broken so that the sound might be heard in background.

After finishing the bug1350947, this situation might be solved too.
(In reply to Alastor Wu [:alwu] from comment #5)
> Same issue as bug1350947.
> 
> ---
> 
> Could you describe the situation about the sound is not muted?
> Do you have any reproduce steps? And does it only happen on Linux?
> Thanks!

I just checked the two PCs used by Emil to test and here are the configurations for those:

- Ubuntu 14.04 32bit: Flash Version 11.2.202.577
-- The sound is not muted only for 1 second or so, when Block Playback icon appears the sound from the video can be heard for 1 second and then it's indeed muted.
-- The video is not paused and is playing in the background.

- Ubuntu 14.04 64bit: Flash Version 24.0.0.221
-- The sound is not muted at all. No particular steps, just open a video from http://www.givemesport.com/ in a new tab and the sound could be heard.
-- The video is not paused and is playing in the background.

After I updated both machines to latest Flash version 25.0.0.127 I could hear (intermittently) for only 1 second the sound from the new tab, just as with 11.2.202.577 version. This applies to both systems. The issue with video not being paused is still here using latest Flash version.

Let me know if there is any info that I missed.
Flags: needinfo?(emil.ghitta) → needinfo?(alwu)

Comment 8

a year ago
Yes, thanks for your help.
It's same as my expected and we would solve the Flash issue in bug1350947.
Flags: needinfo?(alwu)
You need to log in before you can comment on or make changes to this bug.