Closed Bug 1350842 Opened 3 years ago Closed 2 years ago

Remove codes which are related with using external video player to play unsupported type media

Categories

(Core :: Audio/Video: Playback, enhancement, P3)

Other Branch
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1479270

People

(Reporter: alwu, Unassigned)

References

Details

(Whiteboard: [webcompat])

Attachments

(4 files)

Since now we don't support playing HLS with Gecko, we use the external video player, which is created by Android view, to play this kinds of files.

We should remove the related codes [1] after finishing native support.

[1] Eg. https://goo.gl/Q4Hi3K
Priority: -- → P3
Duplicate of this bug: 1382298
Hi Alastor, is it correct that we can fix this bug once Bug 1365505 is resolved? Thanks.
Flags: needinfo?(alwu)
Whiteboard: [webcompat]
Yes, we should remove the workaround after using our native solution as default option (pref-on).
Flags: needinfo?(alwu)
Depends on: 1365505
Hi, handsome James,
Do you have interest in taking this bug?
Feel free to remove the NI if you don't have interest.
Thanks!
Flags: needinfo?(jacheng)
Hi most handsome Alastor,
Please ni your manager first since they have some discussion whether they want to keep this workaround feature not only for HLS.

IMO, I want to leave this feature. 

Thanks.
Flags: needinfo?(jacheng)
Per comment5.
Flags: needinfo?(bwu)
Most handsome Alastor and James (listed in alphabetical order), 
You are both funny and handsome. :-) 
To have a consistent user experience, it would be good to remove those codes.
Let me know if you see any reasons that we should keep it.
Flags: needinfo?(bwu)
Intuitively, if I were user, I cannot play the video and I will try using Chrome and it usually works.

I will remove my Firefox permanently since Chrome is more comprehensive and I have no reason to use Firefox at all.
Which format/link Firefox can not play it and Chrome can play?
(In reply to James Cheng[:JamesCheng] from comment #8)
> Intuitively, if I were user, I cannot play the video and I will try using
> Chrome and it usually works.
> 
> I will remove my Firefox permanently since Chrome is more comprehensive and
> I have no reason to use Firefox at all.

It's based on the way we use to play video is robust, but now that mechanism is just a mess.
I would prefer to remove it, or using other external player to play it (if any).
I could list lots of disadvantage of present external video player,

(1) break the error handling (bug1382298)
- we make the exception not to throw error when playing the unsupported type media
(2) doesn't request the Android's audio focus
- it would interfere other app, causing two different app playing at the same time
(3) doesn't request firefox's internal audio focus
- it would cause two different audio playing at the same time
(4) doesn't provide the media control interface
- user couldn't easily control the video via system notification bar

---

But now I can't trigger our external video player on Firefox release 54, I guess it might have been broken at some time but we didn't noticed that.

Test website : http://mb.ntd.tv/2017/06/12/strong-quake-shakes-turkey-and-greek-islands/
Assignee: nobody → alwu
We may need to keep it alive for a while due to bug 1389990. Let's wait for the conclusion in that bug.
(In reply to Blake Wu [:bwu][:blakewu] from comment #21)
> We may need to keep it alive for a while due to bug 1389990. Let's wait for
> the conclusion in that bug.

OK, let's wait for it.
Duplicate of this bug: 1334152
Assignee: alastor0325 → nobody
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1479270
You need to log in before you can comment on or make changes to this bug.