Closed Bug 13513 Opened 21 years ago Closed 20 years ago

takes more than one click to remove list

Categories

(Core :: DOM: Editor, defect, P1, major)

defect

Tracking

()

VERIFIED DUPLICATE of bug 28491

People

(Reporter: sujay, Assigned: mozeditor)

References

Details

(Whiteboard: Composer feature work)

using 9/9 build of apprunner

1) launch apprunner
2) launch editor
3) put cursor in front of "This" in the first paragraph
4) make bullet list
5) try removing the list by clicking on bullet list again.

all platforms.
*** Bug 10661 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
fixed
Status: RESOLVED → REOPENED
still a problem in 9/14 builds..
i fixed something that caused this (earlier in this same bug history), and I cant
see it now.  But I saw it happen for Sujay (after my fix went in).  I'll try soem
more after a fresh pull.  cc'ing buster and kin in case they get a chance to try
to reproduce this one.
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen of this bug.

Also, this needs a Target Milestone entered please.
I'm seeing this too in my 09/15/99 Win32 build.
Adding sfraser@netscape.com and cmanske@netscape.com to the Cc list.

The fact that the insert bullet list button is not getting updated properly is
the problem. If you look at EditorInsertList() function in EditorCommands.js, it
will only remove the list if the bullet list button is depressed.

After Joe's code makes something into a list, the bullet button on the toolbar
does not accurately reflect this change. It remains unpressed.
Assignee: jfrancis → sfraser
Status: REOPENED → NEW
based on kin's comments, reassigning to simon
I think this and 14220 are one and the same problem.
Target Milestone: M12
asked Sujay to check this out to see if it is still an issue.
yes still an issue.....leave this bug open please...
Target Milestone: M12 → M14
moving this over to M14
yes this bug ist still alive...very easy to reproduce...

basically it takes two clicks to un-list something...
moving to m16
Target Milestone: M14 → M16
*** Bug 28516 has been marked as a duplicate of this bug. ***
Add keyword beta1 based on another bug.  Here are some comments from Bijal in 
another bug:

------- Additional Comments From bijals@netscape.com  2000-02-18 15:49 -------
Would like PDT to review this because this is a top level icon which gets used 
often.

------- Additional Comments From bijals@netscape.com  2000-02-18 15:55 -------
Fequency of feature: Very high since this occurs in email compose as well as 
document compose
UI Discoverability of Feature: Very high since the bullet icon is on Composer 
toolbar
Keywords: beta1
cc bijals
*** Bug 28468 has been marked as a duplicate of this bug. ***
*** Bug 28491 has been marked as a duplicate of this bug. ***
Putting on PDT- radar for beta1.
Whiteboard: [PDT-]
adding EB to status summary...ender blocker...
Whiteboard: [PDT-] → [PDT-] EB
Do we have a fix for this yet?
i was holding off on this until an xpfe button state problem was fixed.  now that 
it is (i think so anyway), i can try to get the editor to set the button state.  

we don't have a fix now.  i think i can fix it pretty soon, though.  stay tuned..
Status: NEW → ASSIGNED
joe says he can fix this. reassign.
Assignee: sfraser → jfrancis
Status: ASSIGNED → NEW
updating keyword and status whiteboard to reflect that this is a beta 2 feature 
work bug that the Composer team deems a must fix for beta 2.
Severity: normal → major
Keywords: beta1beta2
Priority: P3 → P1
Whiteboard: [PDT-] EB → Composer feature work
i accept Bugzilla as my lord and savior.  
Status: NEW → ASSIGNED
Is this the same bug as 28491?
Yes, it is the same bug as 28491. 


*** This bug has been marked as a duplicate of 28491 ***
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → DUPLICATE
verified in 4/17 build.
Status: RESOLVED → VERIFIED
Keywords: nsbeta2
You need to log in before you can comment on or make changes to this bug.