Closed Bug 1351480 Opened 3 years ago Closed 3 years ago

Update webrender to 7463ae5908ca1d4065763a8753af5d72a6f78b85

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(9 files)

59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
jerry
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
+++ This bug was initially created as a clone of Bug #1349692 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ 306d33ec7cbbcc4cb5805967f125dbcd572bc7cb

https://treeherder.mozilla.org/#/jobs?repo=try&revision=87e251b03f5d48feee2c18bd2e105c4e07344737

Busted, method `request_blob_image` has 4 parameters but the declaration in trait `webrender_traits::BlobImageRenderer::request_blob_image` has 5
WR @ ea1e9805599d76394e06ca40900970d207672483 with compile fixes from last time

https://treeherder.mozilla.org/#/jobs?repo=try&revision=78a0e2bcd0f745b849945b58523e4d756336bae2

Builds, but a lot of failures. It looks like giant canvas things are broken again. Debug jobs are all orange.
Above comment was wrong. Here's the real regression range, with a graph for easier visualizing/bisecting (blasted merge commits!)

*   ea1e980 Auto merge of #1022 - mrobinson:u64-id, r=kvark
|\
| * 1c38be3 Have ScrollLayerId use u64
|/
*   306d33e Auto merge of #1021 - glennw:bg-opt, r=mrobinson
|\
| * df3bbb5 Remove a redundant full screen rectangle being drawn each frame.
* |   8f92619 Auto merge of #1004 - nical:blob-img-updates, r=glennw
|\ \
| |/
|/|
| * 80b500a Treat updating non-existant images as an error.
| * 851d683 Clarify the effects of size, format and tiling when updating an image.
| * 086f912 Allow updating images that are not raw buffers.
| * e2fc85e Replace an if/else expression by a match.
* 8b6640f Auto merge of #1015 - glennw:clip-in-out, r=kvark
* 44a7cd2 Address review comments.
* 85c8777 Add support for clip in/out.
WR @ 6b1b85301244d22e5a7f6257e1289c18bc0f0335

https://treeherder.mozilla.org/#/jobs?repo=try&revision=5307611b4b287837baa77e519956dc8643483314

Bustage again

====

WR @ 4b72bb1921628d01b08ab356c0f2365a927b711e, with bustage fixup

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b96726c4cf97169672cc938067d1f0c97a09e40c

Green (except for the X6 failure which is bug 1351777)
It looks like one of the gradient API changes in that push and another one has landed upstream.

I have a patch for wr_bindings for both the changes so I could test things, it might be useful here. It's included in this try run in the 'update wr bindings' cset.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f33df7c2d57d521475649fd77c3c9faed1e97a94
That try push doesn't look very happy either :/. But thanks for the patch, I'll include it in my automated try pushes.
Yeah the try run has layers.advanced.background-image enabled so if you don't have that patch we should be fine.
Ah, that makes sense.

WR @ 384a434d1be0cbc53f79b007fc4cda00b2956400 with various fixups

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ef7e2e787f9fecd5f91a365d96567113bdc9a2ed

Looking better. There's an R4 failure which is an UNEXPECTED-PASS so that's ok.
Blocks: 1323612
WR @ 7463ae5908ca1d4065763a8753af5d72a6f78b85 with fixups

https://treeherder.mozilla.org/#/jobs?repo=try&revision=37b064409e601c7cdb2ec096a73d8ced5c963360

Green, so I'm gonna try and get this landed.
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 7463ae5908ca1d4065763a8753af5d72a6f78b85
Comment on attachment 8854271 [details]
Bug 1351480 - Update webrender and webrender_traits to 7463ae5908ca1d4065763a8753af5d72a6f78b85.

https://reviewboard.mozilla.org/r/126202/#review128930
Attachment #8854271 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8854272 [details]
Bug 1351480 - Update Cargo.toml and Cargo.lock files.

https://reviewboard.mozilla.org/r/126204/#review128932
Attachment #8854272 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8854273 [details]
Bug 1351480 - Re-vendor rust dependencies.

https://reviewboard.mozilla.org/r/126206/#review128936
Attachment #8854273 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8854274 [details]
Bug 1351480 - Update call to update_image for change in 086f912ea86d053d95e5f4eec00cae0d82ee5dba.

https://reviewboard.mozilla.org/r/126208/#review128942
Attachment #8854274 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8854275 [details]
Bug 1351480 - Update request_blob_image for new parameter added in 086f912ea86d053d95e5f4eec00cae0d82ee5dba.

https://reviewboard.mozilla.org/r/126210/#review128944
Attachment #8854275 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8854277 [details]
Bug 1351480 - Update bindings for gradients.

https://reviewboard.mozilla.org/r/126214/#review128946
Attachment #8854277 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8854278 [details]
Bug 1351480 - set_root_display_list got renamed to set_display_list, so update call sites.

https://reviewboard.mozilla.org/r/126216/#review128948
Attachment #8854278 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8854279 [details]
Bug 1351480 - Mark a test passing again.

https://reviewboard.mozilla.org/r/126218/#review128950
Attachment #8854279 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8854276 [details]
Bug 1351480 - Update calls to add_image to include the ImageData::External wrapper.

https://reviewboard.mozilla.org/r/126212/#review129174
Attachment #8854276 - Flags: review?(hshih) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/156ad88d9cde
Update webrender to 7463ae5908ca1d4065763a8753af5d72a6f78b85. r=jrmuizel
https://hg.mozilla.org/projects/graphics/rev/a0452e40488f
Update calls to add_image to include the ImageData::External wrapper. r=Jerry
https://hg.mozilla.org/projects/graphics/rev/bc30dfd39568
Update bindings for gradients. r=jrmuizel
https://hg.mozilla.org/projects/graphics/rev/6964c11a9c06
Mark a test passing again. r=jrmuizel
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.