The music from youtube does not continue once the Firefox is sent to background

RESOLVED WONTFIX

Status

()

Firefox for Android
Audio/Video
P1
normal
RESOLVED WONTFIX
a year ago
9 months ago

People

(Reporter: u589491, Unassigned)

Tracking

52 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+, firefox52 affected, firefox53 unaffected, firefox54 unaffected, firefox55 wontfix)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
*Environment*
Firefox: Release 52.0.2
OS: Android 7.0

*Steps to reproduce*
1. Run Firefox.
2. Go to youtube.com.
3. Play any video (with sound).
4. Send Firefox to background and observe the behavior.

*Expected results*
The music continues in background and media controls are available in the notification list.

*Actual results*
The music is stopped and no controls are available in the notification list.


*Notes*
1. Reproducibility: 5/5.

Updated

a year ago
status-firefox52: --- → affected
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox55: --- → affected
QA Contact: sorina.florean

Updated

a year ago
QA Contact: sorina.florean → bogdan.surd
See Also: → bug 1293963

Comment 1

a year ago
(In reply to Rares Macarie, QA [:RaresM] from comment #0)
> *Environment*
> Firefox: Release 52.0.2
> OS: Android 7.0
If this is reproducible at FF52, then it should has nothing to do with bug 1348085 and bug 1293963. Anyway, I will take a look.
Devices:
 Tablets:
  - Nexus 9 (Android 7.1.1);
  - Xiaomi Mi Pad 2 (Android 5.1); 
  - Huawei MediaPad M2 (Android 5.1.1);
 Phones:
  - HTC Desire 820 (Android 6.0.1);
  - Huawei Honor 8 (Android 6);
  - LG G4 (Android 5.1);
  - LG G4 (Android 6.0);
  - Huawei Honor 5X (Android 5.1.1).

Hello Tzuhao,

 I've looked into this further and the issue does not seem to be reproducible on any of the tablets that I've tested on. The only devices I've managed to successfully reproduce the issue on were the LG G4 (5.1 & 6.0) and the Huawei Honor 5X. I've attached a log from the LG running Android 5.1 that hopefully might help you detect where the issue is.
Created attachment 8857378 [details]
log LG G4 (Android 5.1).txt
(Reporter)

Comment 4

a year ago
The devices on which I've managed to reproduce the issue:
Samsung S7 - Android 7.0
OnePlus 3T - Android 7.0

Comment 5

a year ago
Hi Rares and Bogdan,

Thanks for sharing further information and I have also found something interesting. I guess that the reason why we cannot 100% reproduce this issue is that we're loading different Youtube.com versions and so the root cause might not be at Firefox or Android.

The reason why I have this guess is that if you reset your Firefox (via the Android setting > App info > Firefox > Storage > Clear data) and then perform the STR, you're going to have different behaviors (audio keeps playing or audio stops) randomly. At the same time, other websites have consistent behaviors. 

I have tested all Firefox channels (Release, Beta, Aurora, Nightly, and m-c) on an LG G5 (Android 7) and a Sony Z3C (Android 5) and I can reproduce what I described in the previous paragraph. Could you help to test on more devices to confirm the phenomenon?

Comment 6

a year ago
Sorry, my LG G5 runs Android 6.
(Reporter)

Comment 7

a year ago
Hi Tzuhao,
I've followed your notes and after clearing the data from Android settings I came to the conclusion that you mentioned: the behavior is not consistent. Sometimes the scenario is reproducible, sometimes not. I was not able to find a specific pattern why is that. I repeated the same scenario several times. I've also tried to see if there are errors thrown in the console but no luck (attached logSTR.txt).

Tested on:
Samsung S7 - Android 7.0
OnePlus 3T - Android 7.0

Firefox release 52.0.2.
(Reporter)

Comment 8

a year ago
Created attachment 8857837 [details]
log - Samung S7 - Android 7.0.txt
(Reporter)

Updated

a year ago
Attachment #8857837 - Attachment description: log STR.txt → log - Samung S7 - Android 7.0.txt
Phones:
 - 2x Nexus 5 (Android 6.0.1);
 - HTC 10 (Android 6.0.1);
 - Motorola Razr (Android 4.4.4);
 - Prestigio Grace X5 (Android 4.4.2);
 
Tablets:
 - Asus ZenPad 8.0 Z380KL (Android 6.0.1);
 - Lenovo Yoga Tablet 2 (Android 4.4.2);

Hello Tzuhao,

 I've tested on some more devices following your instructions and I was able to reproduce it on both of the Nexus 5 devices.

 I've tried a new scenario where I uninstalled and reinstalled the app and the issue did not reproduce anymore. Did the same thing of one of the LG devices from yesterday and it also fixed the issue. It would seem that after a fresh install the problem is fixed on my end.

Notes:
I. As for yesterdays tests here are the steps that I followed:

  1. Update the Nightly/Release builds to the latest version (I am performing app updates using ADB with the -r argument);
  2. Perform a clear data;
  3. Open Nightly/Release and press on the search bar in order to display Top Sites;
  4. Tap on YouTube and play any video;
  5. Minimize the app.

 The issue reproduced yesterday following these steps exactly as described by Rares. But doing a fresh install of the app and not updating it seems to have fixed the problem.

II. The issue did not reproduce on the Release version of Firefox on any of the devices that I tested on yesterday and today, I was only able to reproduce it on Nightly.

Rares could you also try the scenario where you perform a fresh install of Firefox and the latest Nightly and see if the issue still persists?
Flags: needinfo?(rares.macarie)
(Reporter)

Comment 10

a year ago
Hi Tzuhao and Bogdan,
I've tried Bogdan's scenarios - uninstall, then reinstall the app and here are the results:

Release 52.0.2
OnePlus 3T - Android 7.0 - 10/10 tries, did NOT reproduce the issue
Samsung S7 - Android 7.0 - 10/10 tries, DID reproduce the issue

Nightly 55.0a1
OnePlus 3T - Android 7.0 - 10/10 tries, did NOT reproduce the issue
Samsung S7 - Android 7.0 - 10/10 tries, DID reproduce the issue
Flags: needinfo?(rares.macarie)
(In reply to Bogdan Surd, QA [:bogdan] from comment #9)
>  I've tried a new scenario where I uninstalled and reinstalled the app and
> the issue did not reproduce anymore. Did the same thing of one of the LG
> devices from yesterday and it also fixed the issue. It would seem that after
> a fresh install the problem is fixed on my end.
No, I tried to re-install the Firefox several times and the problem are still there: keep resetting the Firefox and I still encounter inconsistent behaviors of Youtube.com (audio keeps playing or audio stops).
Per comment 1 and the findings above, this should have nothing to do with suspend-video-decoder feature, remove the dependencies.
No longer blocks: 1348085
See Also: bug 1293963
(In reply to Tzuhao Kuo [:kaku] from comment #5)
> I guess that the reason why we cannot 100% reproduce this issue is that we're loading different Youtube.com versions and so the root cause might not be at Firefox or Android.

BTW, :bwu has some information might support this guess, he might leave some comments later.

Updated

a year ago
See Also: → bug 1353273
Hello,

 While verifying bug 1348085 & bug 1348864 I've noticed that the issue seems to be constantly reproducible now on the latest Nightly build(2017-04-17) on some devices (HTC Desire 820 - 6.0.1, LG G4 - 5.1, Oneplus Two - 6.0.1).

 The issue reproduced even after a Clear Data or a fresh app install. I think we should investigate further and find a fix since it might affect other devices.
tracking-fennec: --- → ?
[triage]
From product perspective this is a regression that causes feature not working as expected.
So i'm setting P1 here.

:bwu can media team help?
tracking-fennec: ? → +
Flags: needinfo?(bwu)
Keywords: regression
Priority: -- → P1
It is discussed in Bug 1357412 as well. 
BTW, could you let me and John Lin to set the priority? We use that to prioritize our resource. 
As we discuss in the bug 1357412, it seems we may not be able to do any thing to fix this quickly since it may be related to Youtube behavior.
Depends on: 1357412
Flags: needinfo?(bwu)
(In reply to Blake Wu [:bwu][:blakewu] from comment #16)
> It is discussed in Bug 1357412 as well. 
> BTW, could you let me and John Lin to set the priority? We use that to
> prioritize our resource. 
> As we discuss in the bug 1357412, it seems we may not be able to do any
> thing to fix this quickly since it may be related to Youtube behavior.

The P1 setting was per the Fennec triage meeting.
We concluded that from product standpoint since unfortunately we didn't have media team attending in person.
Anyways, we surely can alter it with the proper discussion on bugzilla.
on my pixel with 7.1.2, only beta from Google play (53.0b11) works as expected in the background/screen off. The feature isn't working on Release,Aurora,Nightly on the same phone.
See Also: → bug 1358412

Updated

a year ago
Duplicate of this bug: 1358745

Updated

a year ago
Duplicate of this bug: 1358349

Updated

a year ago
Duplicate of this bug: 1353273

Comment 22

a year ago
I'm also experiencing this issue on various channels (Firefox, Firefox Beta, Nightly)
Using Samsung Galaxy S5 G900F Android 6.0.1.
As others, I can't reproduce it 100% of the time. Sometimes clearing Firefox's data helps, sometimes it doesn't.
Hello,

I did a regression window for this issue on a device where it was 100% of the times reproducible (LG G4 - 5.1) and here are the results:

Last known good build: 2017-03-09
First known bad build: 2017-03-10
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c40ca7a1bdd93632c6bdc5e23bd33d984d508b19&tochange=a8d497b09753c91783b68c5805c64f34a2f39629
@Bogdan: A mozregression update (2.3.11) will hopefully be out soon - in the meantime, you can get inbound/autoland bisection going again by manually copying this change (https://github.com/mozilla/mozregression/commit/97178fc26508cd4f9673fd6f57366156912a61f9) into your local mozregression installation.

Comment 25

a year ago
One of the users mentioned on Facebook that opening a youtube page as a desktop version can be a workaround.
Just tried- it works.
Duplicate of this bug: 1361468
Duplicate of this bug: 1362765

Comment 28

a year ago
¡Hola!

Ended up here form a SuMo question.

I believe this is Alphabet trying to corner users into getting https://www.youtube.com/red/ as background playback is being touted as a feature.

¡Gracias!
Alex
No longer depends on: 1363121

Comment 29

a year ago
Youtube Red is not even available in my country ...

Comment 30

a year ago
¡Hola Stephan!

FWIW I've found https://addons.mozilla.org/En-us/firefox/addon/video-background-play-fix/ while trying to help a fellow user in the SuMo Spanish forums.

¡Gracias!
Alex
Snorp, what should we do with this bug?
Flags: needinfo?(snorp)
Most of the work around this has been in bug 1357412

The gist is that this is a YouTube change and there isn't much we can do by default to help, but may be possible via an extension.
Flags: needinfo?(snorp)
Thanks snorp. Given that it's a change from an external site let's not track as a Gecko regression. Someone else can decide if they want to WONTFIX the actual bug (or not), or move it to Tech Evangelism or whatever.
status-firefox55: affected → wontfix
Keywords: regression

Comment 34

a year ago
Would it be possible to make video playback API functions a no-op while the page is in the background, giving 100% control to the user via the notification's pause/rewind/etc buttons?
As comment 32 and 33 pointed out, close this bug as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
Keywords: stale-bug

Comment 36

9 months ago
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #32)
> Most of the work around this has been in bug 1357412
> 
> The gist is that this is a YouTube change and there isn't much we can do by
> default to help, but may be possible via an extension.

I am not authorized to view that bug.

I am not sure that position is defensible, as Firefox does things like block popups. Popups are created at the behest of an external site. Should I file a bug report about the popup blocking functionality of Firefox being inappropriate?

This is a case of a webpage subverting the user's expectations. There is also code in Firefox which relates to media playback that is now useless because of possible misuse of new JavaScript API.

Comment 37

9 months ago
In addition to seconding R030t1's comments, I'd like to add that being able to listen to youtube videos in the background was one of the biggest drawers to Firefox FA, after non-rooted ublock. There are hundreds of articles, like this one https://android.gadgethacks.com/how-to/quick-tip-use-firefox-play-youtube-videos-background-0173597/, that recommend downloading Firefox as a solution to youtube videos not playing in the background. For non-FF desktop users/syncers, what unique advantages are left for this mobile browser?

Comment 39

9 months ago
(In reply to Blake Wu [:bwu][:blakewu] from comment #38)
> FYI. https://support.mozilla.org/en-US/kb/some-videos-wont-play-background

Thank you, I couldn't remember the page that told me about the page visibility API, or what it was called.

However that doesn't explain anything and just reinforces my point. By the logic on that article, if you visit a page that creates new windows using JavaScript then Firefox should not prevent them from being opened. Again: Should I file a bug about the current popup-blocking behavior of Firefox?
You need to log in before you can comment on or make changes to this bug.