Closed Bug 1356217 Opened 3 years ago Closed 3 years ago

[Regression] Spotlight Search still shows the last visited site even after Clear Private Data

Categories

(Firefox for iOS :: General, defect, P1)

All
iOS
defect

Tracking

()

VERIFIED FIXED
Iteration:
1.27
Tracking Status
fxios 8.2 ---
fxios-v8.0 --- affected
fxios-v8.1 --- verified
fxios-v8.2 --- verified
fxios-v9.0 --- verified

People

(Reporter: SimonB, Assigned: justindarc)

References

Details

(Keywords: regression, Whiteboard: [MobileCore][papercut])

Attachments

(1 file)

Build: 58b02370e25
Device: iPad Air 2
iOS: 10.3.1

Steps to reproduce;
1. Go to a website (e.g. soundcloud.com)
2. Close the tab
3. Open Menu -> Settings -> Clear private data
4. Close Firefox
5. Swipe down on iOS screen to open Spotlight Search
6. Type soundcloud

Actual results:
- Soundcloud.com will be displayed in Spotlight Search results

See a video here: https://www.youtube.com/watch?v=12Ng96HWfpU

Note: 
- After step 5) if we repeat the steps to reproduce with a different site (e.g. youtube.com), Soundcloud will no longer be displayed in the Spotlight Search results. The newly visited site (e.g youtube.com) will be displayed instead.
If we're still leaking data, we should consider disabling the feature.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1346573
tracking-fxios: ? → ---
Re-opening as this is not a duplicate of Bug 1346573, it is a case which, I think, was not covered by the patch from Bug 1346573. 

After following the STR, Clearing Private Data deletes the Spotlight search results, except the last visited site.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
tracking-fxios: --- → ?
I think :jhugman you already had a patch for this. Is this a regression of that patch?
Flags: needinfo?(jhugman)
Priority: -- → P2
Whiteboard: [MobileCore]
The Spotlight database is correctly cleared.

This bug is about the NSUserActivity that hangs around, which we should also clear with the NSUserActivity APIs. (Not part of Spotlight AFAIK)
Flags: needinfo?(jhugman)
Whiteboard: [MobileCore] → [MobileCore][papercut]
Priority: P2 → P1
I think this needs us to close open tabs as part of clear private data.

(once the tab is closed, the NSUserActivity is invalidated).
(In reply to James Hugman [:jhugman] [@jhugman] from comment #6)
> I think this needs us to close open tabs as part of clear private data.
> 
> (once the tab is closed, the NSUserActivity is invalidated).

I think we can invalidate NSUserActivity without closing the tabs. If you Clear Private Data on desktop, it still keeps all your tabs open even though they're no longer in history.
Assignee: nobody → jdarcangelo
Status: REOPENED → ASSIGNED
Also, if you watch the video, he closes the tab before clearing history and it still doesn't clear it from Spotlight.
See Also: → 1381604
Attached file GitHub Pull Request
Attachment #8888916 - Flags: review?(fpatel)
Attachment #8888916 - Flags: review?(fpatel) → review+
Landed on master:

https://github.com/mozilla-mobile/firefox-ios/commit/e47b13785bd9f04638917fe9a9855722e33986ce
Status: ASSIGNED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Whiteboard: [MobileCore][papercut] → [MobileCore][papercut][needsuplift]
Iteration: --- → 1.25
Verifying as fix on master c85027eaa0.
Iteration: 1.25 → 1.26
Uplifted to v8.x
Whiteboard: [MobileCore][papercut][needsuplift] → [MobileCore][papercut]
Verifying as fix on 8.1(4811).
Status: RESOLVED → VERIFIED
I have re-opened this bug and moved it to 8.2 because we are getting Core Spotlight crashes at app startup now as reported in bug 1385217.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
What I forgot to mention is that I rolled back the patch for this bug in 8.1. We have never seen crashes for CoreSpotlight before, and since this patches changes that behaviour in our app, I think there is a correlation. Will ask QA to verify if their reproducible crash will go away without this patch.
See notes in bug 1385217 how this story is developing.
Whiteboard: [MobileCore][papercut] → [MobileCore][papercut][needsuplift]
See Also: → 1385217
Iteration: 1.26 → 1.27
Uplifted back into v8.x
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Whiteboard: [MobileCore][papercut][needsuplift] → [MobileCore][papercut]
Verifying as fix on beta 8.2(5120).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.