Last Comment Bug 135689 - Address Book Quick Search on Outlook Express fails
: Address Book Quick Search on Outlook Express fails
Status: RESOLVED EXPIRED
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Address Book & Contacts (show other bugs)
: Trunk
: x86 Windows NT
-- normal with 1 vote (vote)
: ---
Assigned To: mail
:
:
Mentors:
Depends on: 118119
Blocks: 213274
  Show dependency treegraph
 
Reported: 2002-04-05 07:40 PST by John Marmion
Modified: 2010-04-28 13:25 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch to fix Qucik/Advanced Search in OE. (2.43 KB, patch)
2002-04-05 07:43 PST, John Marmion
no flags Details | Diff | Splinter Review

Description User image John Marmion 2002-04-05 07:40:57 PST
Mozilla has the ability to dynamically access both Outlook and Outlook Express
Address Books following the landing of bug #78931 and bug #83103 respectively.
This feature was recently lost: see bug #118119. This overall feature seems to
have lost some momentum. Anyway, with the landing of the Address Book Quick and
Advanced Search recently, Outlook Express returns no results from either of
these searches. The attached patch fixes this. It is still not perfect as there
are some inconsistent results which are down to the WAB interface, nevertheless
this patch is a huge improvement on no results at all. I believe it is worth
attaching if/when this overall functionality comes back on the Mozilla radar.
Comment 1 User image John Marmion 2002-04-05 07:43:38 PST
Created attachment 77846 [details] [diff] [review]
Patch to fix Qucik/Advanced Search in OE.
Comment 2 User image (not reading, please use seth@sspitzer.org instead) 2002-11-17 23:38:06 PST
john, are you still trying to get this into mozilla?

dmose and I were just talking in irc about openoffice and abzilla

Is http://abzilla.mozdev.org still up to date?
Comment 3 User image John Marmion 2002-11-22 08:40:26 PST
Sean (sean.gao@sun.com) will be looking after this and http://abzilla.mozdev.org
It needs to be cleaned up following the landing of some Outlook/Express  related
bug fixes over the past while.
Comment 4 User image Al Maw 2002-12-06 20:30:07 PST
Just adding myself to the cc list. Activity on abzilla seems limited atm, but
I'm trying to set up sync between e-mail address book in Mozilla and PocketPC
(my iPAQ). It seems the only sensible way to do this at the moment is by syncing
with Outlook, and then in turn using MAPI to get at the contacts from Mozilla.

If there's enough interest, I might make an ActiveSync plugin for Mozilla to do
this directly so I can finally uninstall Outlook.

Also, slightly Off-Topic, it'd be nice to pull out birthday details from Outlook
such that the calendar project can do something useful with them.
Comment 5 User image (not reading, please use seth@sspitzer.org instead) 2003-05-08 09:24:53 PDT
mass re-assign.
Comment 6 User image Robert Kaiser 2009-06-14 14:44:20 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 7 User image Robert Kaiser 2010-04-28 13:25:53 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420

Note You need to log in before you can comment on or make changes to this bug.