Crash if 'too many' "www.SITE.com wants to load an image?" dialog boxes

RESOLVED DUPLICATE of bug 133633

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 133633
16 years ago
13 years ago

People

(Reporter: Peter Hicks, Assigned: Matti)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313
BuildID:    2002031312

With 'Ask me before downloading images' checked, visiting a site with frames (or
a site where images are to be loaded from more than one server), so many 'Do you
want to load this image?' dialog boxes appear that Mozilla crashes.

Reproducible: Always
Steps to Reproduce:
1. Turn on 'Ask me before downloading images'.
2. Visit a site (such as Geocities, or one of the many MSN sites) that will load
images off several servers.
3. Watch Mozilla die.

Actual Results:  Browser crashed and brought up the 'Talkback' window

Expected Results:  Still worked! :)

TB4864259Z, TB4829598M, TB4829595E, TB4825543M, TB4806172Q, TB4805532G,
TB4805129W, TB4804496E... and many more!

I'm runinng Slackware Linux 2.4.19-pre5, glibc 2.2.5, gtk 1.2.10, glib 1.2.10
(Assignee)

Comment 1

16 years ago
CC Sarah for the talkback stack trace
Keywords: crash

Comment 2

16 years ago
see bug 110112, bug 110269, bug 128677, bug 126092, bug 133433 - which all may
be duplicates of bug 57188
(Reporter)

Comment 3

16 years ago
Similar to those possible duplicates, but not 100% identical - closing one
confirmation dialog box when more than two are already open causes a crash.

Comment 4

16 years ago
the crash is caused by having more than one dialog, which would be fixed by bug
57188.
bug 133633 seems to be the official image-warning-crasher bug.

*** This bug has been marked as a duplicate of 133633 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.