Closed Bug 1358156 Opened 3 years ago Closed 3 years ago

Update webrender to 1437cc124696ecc95b726dffa17f918bb6ea5af1

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(6 files)

+++ This bug was initially created as a clone of Bug #1357392 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ b941936979b6f00945ced6f9f0d6cd9ec21b5b0f

https://treeherder.mozilla.org/#/jobs?repo=try&revision=0860c673248e4f3bdbdc757d65b9768752c585bd

R4 failure in layout/reftests/bugs/1156129-1.html. The last known good cset was f3fa3481aac63ac93c6ccbe805379875e24e5b77, so the regression range is:

*   b941936 Auto merge of #1148 - rlhunt:composite/clear, r=glennw
|\
| * 191273c Clear render targets with rgba(0,0,0,0) and remove isolate_clear
*   861fb7b Auto merge of #1142 - glennw:double-double-border-2, r=kvark
|\
| * af79505 Add support for double style borders to new border path.
* 88011fc Auto merge of #1141 - changm:textshadow, r=kvark
* 42a2b03 Correctly use the proper text blur cache render task index

I'll bisect to isolate the regressor.
Merging 8ca10a8d56854bc6c025dc2de8053d83fdc88359 will require this patch:

diff --git a/gfx/layers/wr/WebRenderMessageUtils.h b/gfx/layers/wr/WebRenderMessageUtils.h
--- a/gfx/layers/wr/WebRenderMessageUtils.h
+++ b/gfx/layers/wr/WebRenderMessageUtils.h
@@ -179,16 +179,16 @@ struct ParamTraits<WrBuiltDisplayListDes
   Write(Message* aMsg, const WrBuiltDisplayListDescriptor& aParam)
   {
     WriteParam(aMsg, aParam.display_list_items_size);
-    WriteParam(aMsg, aParam.serialization_start_time);
-    WriteParam(aMsg, aParam.serialization_end_time);
+    WriteParam(aMsg, aParam.builder_start_time);
+    WriteParam(aMsg, aParam.builder_finish_time);
   }
 
   static bool
   Read(const Message* aMsg, PickleIterator* aIter, WrBuiltDisplayListDescriptor* aResult)
   {
     return ReadParam(aMsg, aIter, &aResult->display_list_items_size)
-        && ReadParam(aMsg, aIter, &aResult->serialization_start_time)
-        && ReadParam(aMsg, aIter, &aResult->serialization_end_time);
+        && ReadParam(aMsg, aIter, &aResult->builder_start_time)
+        && ReadParam(aMsg, aIter, &aResult->builder_finish_time);
   }
 };
(sorry just to be clear, that's only a PR right now)
88011fcc858153cddf26fdbbef05534f0c579dc7 is green [1]
861fb7b5570d69de37d8a1f364f42f38c87cb2d3 is green [2]

Therefore the regression must be coming from 191273c (servo/webrender#1148).

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=e61746850acd81cb4100000d953d6c7b695b9ddc
[2] https://treeherder.mozilla.org/#/jobs?repo=try&revision=1367dfeea99d69d052f63ddea41d24f3527a88f0
WR @ e83811f82698bea6667e1572549553a6473211ea

https://treeherder.mozilla.org/#/jobs?repo=try&revision=eaa37f27aaab17a5d5a1dbb75a86a1da236fbb95

Same R4 failure, plus an UNEXPECTED-PASS for /layout/reftests/bugs/632781-verybig.html.
The R4 failure should be fixed by [1].

[1] https://github.com/servo/webrender/pull/1156
WR @ 0d2ec6ce28cc28c1bc13ace148b6cf9c03eadc8a

https://treeherder.mozilla.org/#/jobs?repo=try&revision=807d71b8b49a371e7b5e788d4c76b6a805105a13

The old R4 failure is fixed, and we have two additional UNEXPECTED-PASS tests in R4. yay!
WR @ 1437cc124696ecc95b726dffa17f918bb6ea5af1

https://treeherder.mozilla.org/#/jobs?repo=try&revision=2ca0fd2ce11946bc14f2daf884db189d04b12953

Bustage, looks like push_stacking_context doesn't take a z-index any more.
WR @ 1437cc124696ecc95b726dffa17f918bb6ea5af1 with z-index fixup

https://treeherder.mozilla.org/#/jobs?repo=try&revision=57261b30306127cf0382e03e9a074abd075364c5

Green. I'm going to land an update now.
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 1437cc124696ecc95b726dffa17f918bb6ea5af1
Comment on attachment 8861840 [details]
Bug 1358156 - Update a couple of field names as a result of 8ca10a8.

https://reviewboard.mozilla.org/r/133850/#review136730
Attachment #8861840 - Flags: review?(bugmail) → review+
Comment on attachment 8861843 [details]
Bug 1358156 - Remove z-index related goop, since it's no longer needed as of c872232.

https://reviewboard.mozilla.org/r/133856/#review136846
Attachment #8861843 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8861838 [details]
Bug 1358156 - Update webrender to 1437cc124696ecc95b726dffa17f918bb6ea5af1.

https://reviewboard.mozilla.org/r/133846/#review136848

::: gfx/webrender/examples/basic.rs:1
(Diff revision 1)
> +/* This Source Code Form is subject to the terms of the Mozilla Public

Do you think it's worth not adding the examples to mozilla-central?
Attachment #8861838 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8861839 [details]
Bug 1358156 - Update Cargo.toml/Cargo.lock files and generated FFI header.

https://reviewboard.mozilla.org/r/133848/#review136850
Attachment #8861839 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8861841 [details]
Bug 1358156 - Mark a test as passing with webrender, from cset c3995c8.

https://reviewboard.mozilla.org/r/133852/#review136852
Attachment #8861841 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8861841 [details]
Bug 1358156 - Mark a test as passing with webrender, from cset c3995c8.

https://reviewboard.mozilla.org/r/133852/#review136854
(In reply to Jeff Muizelaar [:jrmuizel] from comment #21)
> Do you think it's worth not adding the examples to mozilla-central?

I don't know if cargo will be very happy if we just omit the example files without modifying the Cargo.toml. Even if it works now, I doubt it's guaranteed to work in the future. And I'd rather not muck around with the Cargo.toml files manually, it will make updating more error-prone.
Comment on attachment 8861842 [details]
Bug 1358156 - Mark a couple more tests as passing with webrender, from 3c2c2b0.

https://reviewboard.mozilla.org/r/133854/#review136864
Attachment #8861842 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/147102936b89
Update webrender to 1437cc124696ecc95b726dffa17f918bb6ea5af1. r=jrmuizel
https://hg.mozilla.org/projects/graphics/rev/55f0e9adcbd7
Mark some tests as passing with webrender, from csets c3995c8 and 3c2c2b0. r=jrmuizel
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.