Typos in mail account wizard

VERIFIED FIXED in M13

Status

SeaMonkey
MailNews: Account Configuration
P3
normal
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview: Going through the Account Setup Wizard for the first time found the
following appearance problems and typos. Please refer to the Account Setup Spec.

A. 1st Dialog: New Account Setup
1. The dialog needs to be wider because the Seamonkey icon in top right is cut
off.
2. The title should state "New Account Setup". It currently states "Welcome to
the Account
Setup Wizard".
3. The first paragraph should state

"This Wizard will collect the information necessary to setup a new Netscape Mail
account. If
you do not know the information requested, please contact your System
Administrator or
Internet Service Provider.

Select the type of account yu would like to setup:"

followed by the radio button items which are in the correct order.

B. 2nd Dialog: Identity
1. It should state
1st sentence: "Each account can have its own identity, which is the information
that identifies you to others when they receive your messages.

2nd sentence: "Enter the name you would like to appear in the "From" field of
your outgoing
messages. (For example, "John Smith".)"

3rd sentence: "Enter your email address. This is the address others will use to
send email to you. (For example, "test@netscape.net".)

C. 3rd Dialog: Server Information
1. The dialog needs to be wider because the Seamonkey icon in top right is cut
off.
2. 2nd sentence: "Enter the name of your incoming server. (For example,
"pop.netscape.net".)
3. Half of the text for "Outgoing (SMTP) Server" is cut off.
4. You also can't see anything that should be displayed below this line. For
instance it should state
'Enter the name of your outgoing (SMTP) server. (For example,
"smtp.netscape.net".)'
followed by
"Server Name:" and a text field.

D: 4th Dialog: Name and Password
1. 1st sentence: Should state "Enter your user name given to you by your email
provider. (For example, "jsmith".)"

2. Password Storage: Should state "Netscape Mail can save your password and send
it to the server so that you are not asked for it each time you access this
account. This is not recommended if other people have acces to your computer.

3. The rest of the dialog does not appear, it's cut off.

E: 5th Dialog: Account Name
1. 1st Sentence: Should state "Enter the name by which you would like to refer
to this account. (For example, "Work Account", "Home Account" or "News
Account".)
2. The next line should be blank.
3. The text box should have text dispayed to the left stating "Account Name:".

F: 6th Dialog: Congratulations!
1. The title should state "Congratulations!"
2. The title area should also have a space for the logo to appear in the top
right.
3. "That's it!" should be removed.
4. The dialog should state

'You have entered all the information required to set up this account.

  User Name: jsmith
  Email Address: jsmith@netscape.com

Click "Finish" to save these settings and exit the Account Wizard.

Click "Set up Another" to save these settings and set up another account.'

G. The cursor should appear in the text box automatically in the following
dialogs: Identity, Server Information, Name and Password and Account Name.

H. After entering information into the first text box, press the Tab key and the
cursor should advance to the next text box in the following dialogs: Identity,
Server Information, Name and Password.
(Reporter)

Updated

19 years ago
Assignee: phil → alecf
QA Contact: lchiang → nbaca
(Reporter)

Comment 1

19 years ago
Assigning to alecf, setting QA contact to nbaca and adding lchiang to Cc: list.
(Reporter)

Comment 2

19 years ago
The above report was created using Build 1999091009M11: Win32/NT4.
(Assignee)

Updated

19 years ago
Target Milestone: M11
(Assignee)

Comment 3

19 years ago
*** Bug 13824 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

19 years ago
*** Bug 13159 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

19 years ago
ok, I've fixed all the text related things, layout, etc. You can see the widgets
and everything.

What we have left:
the final page still needs to summarize the account info.

The focus problems and tab behavior are beyond my scope, the product doesn't
even have this capability yet. When it does, these things will just happen
automatically in all dialogs that have text fields. I'm going to consider G and
H to be invalid, and mark this bug fixed when I fix the last page.

Updated

19 years ago
Target Milestone: M11 → M12
(Assignee)

Updated

19 years ago
Target Milestone: M12 → M11

Updated

19 years ago
Blocks: 11091

Comment 6

19 years ago
(target milestone is M11 or M12 - add to beta tracking bug)
(Assignee)

Updated

19 years ago
Summary: Account Wizard Dialogs: strange appearance and typos → Account Wizard Dialogs: Finish page should summarize account
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
ok, this is done.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

19 years ago
Resolution: FIXED → ---
(Reporter)

Comment 8

19 years ago
Build 1999092309M11: Win32/NT4, Linux/Redhate 6.0, Mac 8.5.1
Reopening since these issues need fixing:

A3. 1st Dialog: New Account Setup- The following statement is missing, it should
be placed between the first paragraph and the Mail radio button:

"Select the type of account you would like to setup:" followed by a blank line
and the radio buttons for Mail and News"

D: 4th Dialog: Name and Password
1. 1st sentence: Currently states `Enter your user name given to you by your
email provider. (for example, "jsmith")`. Need to capitalize the "f" so "for"
becomes "For".
3. "Enter the password given to you by your email provider" should have a period
at the end, "provider.".

F: 6th Dialog: Congratulations!
4. Is missing `Click "Finish" to save these settings and exit the Account
Wizard.`. It should appear after the "Email Address:...." entry and before
`Click "Set up Another" to save these settings and set up another account`.
(Assignee)

Updated

19 years ago
Target Milestone: M11 → M12
(Assignee)

Comment 9

19 years ago
thanks.
These issues can wait till M12
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
Component: Front End → Account Manager
(Assignee)

Updated

18 years ago
Summary: Account Wizard Dialogs: Finish page should summarize account → Wizard: Finish page should summarize account
Target Milestone: M12 → M13

Updated

18 years ago
Summary: Wizard: Finish page should summarize account → Typos in mail account wizard
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

18 years ago
ok, these issues are done.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

18 years ago
Build 2000010309M13: NT4, Linux/Redhat 6.0, Mac 8.5.1
Verified Fixed.

Note for Item F4: I spoke with alecf and jglick and we agree that the
explanatin for the "Set up Another" account should be listed first and the
"Finish" button explanation second. The build is correct but the spec needs to
be updated.

Comment 12

18 years ago
UE spec updated :-)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.