Support for IRCnet network

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
enhancement
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: Artem Goutsoul, Assigned: Gijs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.78], URL)

Attachments

(1 attachment)

1.04 KB, patch
James Ross
: review+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
It would be great to have a possibility to use "/attach irc://ircnet" or click
on irc://ircnet links, the same way as for efnet, dalnet and other.

Updated

15 years ago
Severity: normal → enhancement
Summary: RFE: Support for IRCnet network → [RFE] Support for IRCnet network

Comment 1

15 years ago
IRC URLs seem to be working fine. Reporter, what isn't working for you?

Comment 2

15 years ago
I think the issue is that chatzilla doesn't know about ircnet, but it knows
about efnet, dalnet and so on.
At least, that's how I interpret the reporter's comment.

If it's a valid bug, I imagine it's real simple to fix.
(Reporter)

Comment 3

15 years ago
Yes, that's exactly what I meant. Even though the mentioned url does open up a
new chatzilla window, it does not connect anywhere. And I would have expected it
to work exactly like EFNET and the others - connect to one of the IRCnet servers. 

Comment 4

15 years ago
Seems valid; approving.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
i suggest marking this invalid.
ircnet DOES NOT support network masking. the only way to connect to ircnet is by
server (there is no redirection like irc.dal.net or similar, which i presume is
used for /attach dalnet). moreover, ircnet policy is to keep users on their
local servers (geographically) and there are just a few so called "open" servers
that allow connecting form everywhere. If thes changes in the future, you'll be
the first to know. the only other option would be user defined ircnet server
list, to which he can connect to. 

Comment 6

14 years ago
Apparently there is now a global server, irc://irc.ircnet.com/, but they still
don't want you to use it.
Product: Core → Other Applications
(Assignee)

Comment 7

13 years ago
*Crosspost*

I request that bug 135926, bug 227366 and bug 239080 will be marked dependent on
bug 27807, since all these networks can be added when that bug is fixed.

Updated

12 years ago
Depends on: 27807
(Assignee)

Comment 8

11 years ago
Created attachment 248118 [details] [diff] [review]
Patch

"Or try to connect to irc.ircnet.com, which will attempt to connect you to an open server." -- from their website.

So I presume the included patch will do fine. If it doesn't, I expect them to provide an alternative - we can't guess in what part of the world we are and connect people to a 'good' server, so...
Assignee: rginda → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Attachment #248118 - Flags: review?(silver)
(Assignee)

Updated

11 years ago
Summary: [RFE] Support for IRCnet network → Support for IRCnet network

Updated

11 years ago
Attachment #248118 - Flags: review?(silver) → review+
(Assignee)

Comment 9

11 years ago
Checking in mozilla/extensions/irc/xul/content/networks.js;
/cvsroot/mozilla/extensions/irc/xul/content/networks.js,v  <--  networks.js
new revision: 1.4; previous revision: 1.3
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Whiteboard: [cz-0.9.78]
You need to log in before you can comment on or make changes to this bug.