Add irc-hispano to default network list

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
enhancement
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: Alberto García Fernández, Assigned: Gijs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.78], URL)

Attachments

(1 attachment)

1009 bytes, patch
James Ross
: review+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; es-ES; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; es-ES; rv:1.2.1) Gecko/20021130

It would be possible to add irc-hispano to *client* view default networks as
moznet, efnet, dalnet, etc.?

Generic irc: url for irc-hispano is:

irc://irc.irc-hispano.org/

It would be fantastic if chatzilla reconognized irc://irc-hispano/ as a network.

IRC-Hispano <http://www.irc-hispano.org/> is the biggest Spanish language irc
network.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
interesting suggestion, the proposed networks are indeed limited language-wise.
Why not? we have plenty of space available on the startup screen :-)
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
I think a solution for this would documentation about how to manage this kind of
things, because it's supposed that they're not hard-coded into chatzilla code,
so I claim for this better solution.
Product: Core → Other Applications
(Assignee)

Comment 3

13 years ago
*Crosspost*

I request that bug 135926, bug 227366 and bug 239080 will be marked dependent on
bug 27807, since all these networks can be added when that bug is fixed.

Updated

12 years ago
Depends on: 27807
(Assignee)

Comment 4

11 years ago
Created attachment 248119 [details] [diff] [review]
Patch

mIRC seems to refer to the network as just "Hispano" and that seemed more logical to me, too, so I've copied that behaviour.
Assignee: rginda → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Attachment #248119 - Flags: review?(silver)
(Assignee)

Updated

11 years ago
Summary: Add irc-hispano to *client* view default networks → Add irc-hispano to default network list

Comment 5

11 years ago
Comment on attachment 248119 [details] [diff] [review]
Patch

I can't find any confirmation of this address on their appalingly website, but that's their problem now.
Attachment #248119 - Flags: review?(silver) → review+
(Assignee)

Comment 6

11 years ago
Checking in mozilla/extensions/irc/xul/content/networks.js;
/cvsroot/mozilla/extensions/irc/xul/content/networks.js,v  <--  networks.js
new revision: 1.3; previous revision: 1.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Whiteboard: [cz-0.9.78]
You need to log in before you can comment on or make changes to this bug.