uninterruptible reflow at _openAutocompletePopup@chrome://browser/content/urlbarBindings.xml

REOPENED
Unassigned

Status

()

defect
P4
normal
REOPENED
2 years ago
3 months ago

People

(Reporter: marco, Unassigned)

Tracking

(Blocks 2 bugs, {perf})

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p2][reserve-photon-performance])

Reporter

Description

2 years ago
Here's the stack:

openPopupAtScreen@chrome://global/content/bindings/popup.xml:70:15
openContextMenu@chrome://browser/content/nsContextMenu.js:58:3
receiveMessage@chrome://browser/content/tabbrowser.xml:5010:15
Flags: qe-verify?
Priority: -- → P2
Duplicate of this bug: 1360273
Component: Untriaged → General
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1][reserve-photon-performance]
Flags: qe-verify? → qe-verify-
Whiteboard: [ohnoreflow][qf:p1][reserve-photon-performance] → [ohnoreflow][qf:p2][reserve-photon-performance]
I think this one is actually caused by platform code. Around http://searchfox.org/mozilla-central/rev/3a3af33f513071ea829debdfbc628caebcdf6996/layout/xul/nsXULPopupManager.cpp#778 all the nsXULPopupManager::ShowPopup* methods call GetPopupFrameForContent with true as the aShouldFlush parameter.

We also hit this with a different stack when opening the awesomebar panel:

	"openPopup@chrome://global/content/bindings/popup.xml:66:15",
	"_openAutocompletePopup@chrome://browser/content/urlbarBindings.xml:1889:11",
	"openAutocompletePopup@chrome://browser/content/urlbarBindings.xml:1803:11",
	"openPopup@chrome://global/content/bindings/autocomplete.xml:393:13",
	"set_popupOpen@chrome://global/content/bindings/autocomplete.xml:103:10",
	"notifyResults@file:///<appdir>/components/UnifiedComplete.js:2193:5",
Priority: P3 → P4
Keywords: perf
I cannot reproduce this one anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

(In reply to Mike Conley (:mconley) (:⚙️) from comment #3)

I cannot reproduce this one anymore.

browser/base/content/test/performance/browser_urlbar_search.js has two stacks referring to this bug.

Status: RESOLVED → REOPENED
Flags: needinfo?(mconley)
Resolution: WORKSFORME → ---

So it does! Back into the queue it goes.

Flags: needinfo?(mconley)
Summary: 1.00ms uninterruptible reflow at openPopupAtScreen@chrome://global/content/bindings/popup.xml:70:15 → uninterruptible reflow at _openAutocompletePopup@chrome://browser/content/urlbarBindings.xml
You need to log in before you can comment on or make changes to this bug.