Closed Bug 1362393 Opened 3 years ago Closed 3 years ago

Intermittent application crashed [@ mozilla::wr::LockExternalImage]

Categories

(Core :: Graphics: WebRender, defect, P3, critical)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1364302

People

(Reporter: intermittent-bug-filer, Assigned: sotaro)

References

Details

(Keywords: crash, intermittent-failure, Whiteboard: [gfx-noted])

Crash Data

Stack looks like this:

 0  libxul.so!mozilla::wr::LockExternalImage [RendererOGL.cpp:abfd063b18fe : 24 + 0x0]
 1  libxul.so!webrender_bindings::bindings::{{impl}}::lock [bindings.rs:abfd063b18fe : 572 + 0xa]
 2  libxul.so!webrender_bindings::bindings::wr_renderer_render [renderer.rs:abfd063b18fe : 1445 + 0x20]
 3  libxul.so!mozilla::wr::RendererOGL::Render [RendererOGL.cpp:abfd063b18fe : 126 + 0x12]
 4  libxul.so!mozilla::wr::RenderThread::UpdateAndRender [RenderThread.cpp:abfd063b18fe : 186 + 0x5]
 5  libxul.so!mozilla::wr::RenderThread::NewFrameReady [RenderThread.cpp:abfd063b18fe : 125 + 0xb]
 6  libxul.so!mozilla::detail::RunnableMethodImpl<mozilla::wr::RenderThread*, void (mozilla::wr::RenderThread::*)(WrWindowId), true, false, WrWindowId>::Run [nsThreadUtils.h:abfd063b18fe : 874 + 0x1c]
 7  libxul.so!MessageLoop::RunTask [message_loop.cc:abfd063b18fe : 361 + 0x6]
 8  libxul.so!MessageLoop::DeferOrRunPendingTask [message_loop.cc:abfd063b18fe : 369 + 0x5]
 9  libxul.so!MessageLoop::DoWork [message_loop.cc:abfd063b18fe : 444 + 0x5]
10  libxul.so!base::MessagePumpDefault::Run [message_pump_default.cc:abfd063b18fe : 36 + 0xa]
11  libxul.so!MessageLoop::Run [message_loop.cc:abfd063b18fe : 231 + 0x8]
It is possibly related to bug 1362144 as well. In my case it looks like it got the image before it got removed and failed during the unlock, and here it failed to get the image during the lock.
See Also: → 1362144
See Also: → 1364302
Priority: -- → P3
Whiteboard: [gfx-noted]
Assignee: nobody → sotaro.ikeda.g
Happens on other tests too, such as https://treeherder.mozilla.org/logviewer.html#?job_id=99327420&repo=graphics&lineNumber=7379
Summary: Intermittent dom/imptests/html/webgl/test_texImage2D.html | application crashed [@ mozilla::wr::LockExternalImage] → Intermittent application crashed [@ mozilla::wr::LockExternalImage]
Depends on: 1364302
See Also: 1364302
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #4)
> Happens on other tests too, such as
> https://treeherder.mozilla.org/logviewer.
> html#?job_id=99327420&repo=graphics&lineNumber=7379

It happened before bug 1364302 fix. It seems better to wait to see if the crash happens since bug 1364302 fix.
The crash seemed to be addressed by bug 1364302.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1364302
You need to log in before you can comment on or make changes to this bug.