Closed Bug 1364499 Opened 3 years ago Closed 3 years ago

Assertion failure: mRenderTextures.Get(aExternalImageId.mHandle).get(), at gfx/webrender_bindings/RenderThread.cpp:247

Categories

(Core :: Graphics: WebRender, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1364302

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [gfx-noted])

Looks similar to bug 1362393.

Assertion failure: mRenderTextures.Get(aExternalImageId.mHandle).get(), at /home/worker/workspace/build/src/gfx/webrender_bindings/RenderThread.cpp:247
#01: mozilla::wr::LockExternalImage [gfx/webrender_bindings/RendererOGL.cpp:22]
#02: webrender_bindings::bindings::{{impl}}::lock [gfx/webrender_bindings/src/bindings.rs:575]
#03: webrender::renderer::Renderer::update_texture_cache [gfx/webrender/src/renderer.rs:1446]
#04: webrender::renderer::{{impl}}::render::{{closure}} [gfx/webrender/src/renderer.rs:1284]
#05: webrender::profiler::TimeProfileCounter::profile<webrender::device::FrameId,closure> [gfx/webrender/src/profiler.rs:154]
#06: webrender::renderer::Renderer::render [gfx/webrender/src/renderer.rs:1272]
#07: mozilla::wr::RendererOGL::Render [gfx/webrender_bindings/RendererOGL.cpp:128]
#08: mozilla::wr::RenderThread::UpdateAndRender [mozglue/misc/TimeStamp.h:467]
#09: mozilla::wr::RenderThread::NewFrameReady [gfx/webrender_bindings/RenderThread.cpp:126]
#10: mozilla::detail::RunnableMethodImpl<mozilla::wr::RenderThread*, void (mozilla::wr::RenderThread::*)(WrWindowId), true, false, WrWindowId>::Run [xpcom/threads/nsThreadUtils.h:912]
#11: MessageLoop::RunTask [mfbt/RefPtr.h:62]
#12: MessageLoop::DeferOrRunPendingTask [ipc/chromium/src/base/message_loop.cc:369]
#13: MessageLoop::DoWork [ipc/chromium/src/base/message_loop.cc:444]
#14: base::MessagePumpDefault::Run [ipc/chromium/src/base/message_pump_default.cc:37]
#15: MessageLoop::RunInternal [ipc/chromium/src/base/message_loop.cc:239]
#16: MessageLoop::Run [ipc/chromium/src/base/message_loop.cc:505]
#17: base::Thread::ThreadMain [ipc/chromium/src/base/thread.cc:182]
#18: ThreadFunc [ipc/chromium/src/base/platform_thread_posix.cc:40]
#19: libpthread.so.0 + 0x76ba
#20: libc.so.6 + 0x10682d
See Also: → 1362393
This happens a bunch on the media mochitests on linux64-qr jobs.
Blocks: 1334189
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: Intermittent GECKO(3099) | Assertion failure: mRenderTextures.Get(aExternalImageId.mHandle).get(), at gfx/webrender_bindings/RenderThread.cpp:247 → Assertion failure: mRenderTextures.Get(aExternalImageId.mHandle).get(), at gfx/webrender_bindings/RenderThread.cpp:247
Whiteboard: [gfx-noted]
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1364302
You need to log in before you can comment on or make changes to this bug.