Closed Bug 1364302 Opened 3 years ago Closed 3 years ago

Fix HoldExternalImage() handling

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(1 file, 1 obsolete file)

HoldExternalImage() worked correctly when it is implemented. But it seems not work correctly since Bug 1355702 fix.

In the past, ImageKey was generated on every transaction. But now ImageKey is not generated for each transaction. HoldExternalImage() start holding when ImageKey for external image id is created in WebRenderBridgeParent. And end holding its TextureHost when epoc of HoldExternalImage() called was ended on RenderThread.

We do not hold TextureHost for enough period now.
Assignee: nobody → sotaro.ikeda.g
Blocks: 1360701
Blocks: webrender
(In reply to Sotaro Ikeda [:sotaro] from comment #0)
> HoldExternalImage() worked correctly when it is implemented. But it seems
> not work correctly since Bug 1355702 fix.

Bug 1337761 also seems to be related.
Attachment #8867081 - Flags: review?(nical.bugzilla)
Blocks: 1363643
See Also: → 1362144
See Also: → 1362393
Attachment #8867081 - Flags: review?(nical.bugzilla) → review+
Rebased.
Attachment #8867081 - Attachment is obsolete: true
Attachment #8868008 - Flags: review+
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/67ca59cd3d03
Fix HoldExternalImage() handling r=nical
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Blocks: 1362393
See Also: 1362393
Target Milestone: --- → mozilla55
Duplicate of this bug: 1362393
Duplicate of this bug: 1364499
I am still hitting crashes in [@ mozilla::wr::LockExternalImage ] in the latest nightly: https://crash-stats.mozilla.com/report/index/3afeee47-cff4-4bb8-acf1-067ad0170627.

Using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0 ID:20170627100238 CSet: 53477d584130945864c4491632f88da437353356

Sotaro should I file a new bug or should we reopen this one?
Flags: needinfo?(sotaro.ikeda.g)
:marcia, can you file a new bug? Thanks!
Flags: needinfo?(sotaro.ikeda.g)
You need to log in before you can comment on or make changes to this bug.