Update Firefox Screenshots to version 6.6.2

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: _6a68, Assigned: _6a68)

Tracking

unspecified
Firefox 55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 wontfix, firefox55 fixed)

Details

Attachments

(1 attachment)

Adding some more performance tweaks and updating the icon SVGs to look nicer on the dark dev edition theme.

I manually kicked off a Try run with current central + this patch + Screenshots preffed on:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=11c757d70e4fe974a5cac43c9545e1f179a89269
Comment hidden (mozreview-request)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8865012 [details]
Bug 1362550 - Export Screenshots 6.6.2 to Firefox;

https://reviewboard.mozilla.org/r/136670/#review139764
Attachment #8865012 - Flags: review?(kmaglione+bmo) → review+

Comment 5

2 years ago
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6b8416bae412
Export Screenshots 6.6.2 to Firefox; r=kmag

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6b8416bae412
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Comment on attachment 8865012 [details]
Bug 1362550 - Export Screenshots 6.6.2 to Firefox;

Approval Request Comment
[Feature/Bug causing the regression]:
This addresses some of the performance regression in Bug 1361792. There is ongoing discussion in that bug regarding performance requirements. This should be uplifted to update 6.6.0 already pref'd off in Beta.

[User impact if declined]:
This has some perf fixes.


[Is this code covered by automated tests?]:
Some.

[Has the fix been verified in Nightly?]:
Yes.

[Needs manual test from QE? If yes, steps to reproduce]:
No.

[List of other uplifts needed for the feature/fix]:
Some of the features in Bug 1361792 may need to get uplifted, but Kris is working through those.

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
6.6.0 is already in Nightly/Beta, this is an incremental change.

[String changes made/needed]:
None.
Attachment #8865012 - Flags: approval-mozilla-beta?
Here's a try push with 6.6.2 on top of current beta, so we can get a look at the talos regressions there:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8f207c38fd6ffe50f3f79129e06a0b5cd6ef4ed9
And here's a try push with 6.6.2 preffed on by default, on top of current beta:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4fddda5de7c5f3417129916ec784f712e7f643ba
Note that the pushes in comment 8 and comment 9 don't include the WebExtensions performance optimizations currently in progress in bug 1363445.
Assignee: nobody → jhirsch
Apparently the earlier try runs failed because signing was required, and the talos addons are unsigned:
https://treeherder.mozilla.org/logviewer.html#?job_id=97773746&repo=try&lineNumber=1138

I disabled that check and re-pushed:

Beta with Screenshots 6.6.2 disabled:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5e6d89a2faf0d7f883c9e71c7b24f82df057c5f7

Beta with Screenshots 6.6.2 enabled:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c4cd804ad72cefb72353c6da6d2085f665d9a8db

Beta with Screenshots 6.6.2 enabled and Kris's perf fixes cherry-picked in (from bugs 1363445, 1356810, 1356828, 1356827):
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0af4537f17025eaf90791f3054b94724635668f8
> Beta with Screenshots 6.6.2 enabled and Kris's perf fixes cherry-picked in (from bugs 1363445, 1356810, 1356828, 1356827):
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=0af4537f17025eaf90791f3054b94724635668f8

This job failed to build, because I neglected to pick up the refactoring changes in bug 1356666 and bug 1356799.

Once more, with feeling:

Beta with Screenshots 6.6.2 enabled, Kris's perf fixes (from bugs 1363445, 1356810, 1356828, 1356827), and the refactoring changes that touched the same files (from bugs 1356666, 1356799):
https://treeherder.mozilla.org/#/jobs?repo=try&revision=47430e880af1a4ffc0ce7107e0ff8e8bf00e2edd
Hi Jared, 
I'm not sure if my comparison is correct or not. Please correct me if it's wrong. 
I compared the Beta with Screenshots 6.6.0 disabled (by default) with your try - Beta with Screenshots 6.6.2 disabled and found that there are still quite a few regressions. Here is the comparison URL: https://goo.gl/pJndpi. This might need your help to judge if it's really fixed.
Flags: needinfo?(jhirsch)
I'm pretty sure something went wrong with that run. Those regressions are orders of magnitude worse than we saw on central.
Screenshots will go live in Fx55 so we don't have to uplift these patches in 54. Beta54-. Mark 54 won't fix.
status-firefox54: --- → wontfix
Attachment #8865012 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Flags: needinfo?(jhirsch)
You need to log in before you can comment on or make changes to this bug.