--disable-accessibility fails to build

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mats, Assigned: RyanVM)

Tracking

({regression})

55 Branch
mozilla55
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
STR
1. Add "ac_add_options --disable-accessibility" to your .mozconfig
2. build

ACTUAL RESULTS

 3:11.40 In file included from /md1/objdir/md1/src/mc/parser/html/Unified_cpp_parser_html0.cpp:20:
 3:11.40 /md1/src/mc/parser/html/nsHtml5AttributeName.cpp:842:38: error: no member named 'aria_valuemax' in 'nsGkAtoms'
 3:11.40     ALL_NO_NS, SAME_LOCAL(nsGkAtoms::aria_valuemax), ALL_NO_PREFIX);
 3:11.40                           ~~~~~~~~~~~^
 3:11.40 /md1/src/mc/parser/html/nsHtml5AttributeName.cpp:844:38: error: no member named 'aria_labelledby' in 'nsGkAtoms'
 3:11.40     ALL_NO_NS, SAME_LOCAL(nsGkAtoms::aria_labelledby), ALL_NO_PREFIX);
 3:11.40                           ~~~~~~~~~~~^
 3:11.40 /md1/src/mc/parser/html/nsHtml5AttributeName.cpp:846:38: error: no member named 'aria_describedby' in 'nsGkAtoms'
 3:11.41     ALL_NO_NS, SAME_LOCAL(nsGkAtoms::aria_describedby), ALL_NO_PREFIX);
 3:11.41                           ~~~~~~~~~~~^
 3:11.41 /md1/src/mc/parser/html/nsHtml5AttributeName.cpp:848:38: error: no member named 'aria_disabled' in 'nsGkAtoms'
 3:11.41     ALL_NO_NS, SAME_LOCAL(nsGkAtoms::aria_disabled), ALL_NO_PREFIX);
 3:11.41                           ~~~~~~~~~~~^
 3:11.41 /md1/src/mc/parser/html/nsHtml5AttributeName.cpp:850:38: error: no member named 'aria_checked' in 'nsGkAtoms'
 3:11.41     ALL_NO_NS, SAME_LOCAL(nsGkAtoms::aria_checked), ALL_NO_PREFIX);
 3:11.41                           ~~~~~~~~~~~^
...
(Reporter)

Comment 1

2 years ago
A regression from bug 1269490 perhaps?
Blocks: 1269490
Flags: needinfo?(hsivonen)
Keywords: regression
Yes. Fewer atoms should be behind #ifdef ACCESSIBILITY in the atom list.
Flags: needinfo?(hsivonen)
Duplicate of this bug: 1363021
(Assignee)

Comment 4

2 years ago
Created attachment 8865578 [details] [diff] [review]
move some accessibility atoms out of the ACCESSIBILITY ifdef

Fixes the build locally for me. Green on Try too.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8f23fee7b9d52c11404b0801498507855243a510
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #8865578 - Flags: review?(hsivonen)
Attachment #8865578 - Flags: review?(hsivonen) → review+

Comment 5

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7c66e8805fcb
Move some atoms outside of the ACCESSIBILITY guard to fix --disable-accessibility bustage. r=hsivonen

Updated

2 years ago
Duplicate of this bug: 1363478

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7c66e8805fcb
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Assignee)

Updated

2 years ago
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox-esr52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.