Intermittent browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | recording-window-ended notification unexpected - Got -1, expected 0

RESOLVED FIXED in Firefox 54

Status

()

defect
P1
normal
Rank:
19
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: pehrsons)

Tracking

({intermittent-failure})

unspecified
mozilla55
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 wontfix, firefox54 fixed, firefox55 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Probably because we re-enabled tests in bug 1320994. Andreas, thoughts?
Rank: 19
Flags: needinfo?(pehrson)
Priority: -- → P1
I did an analysis of where these errors could come from and found a hole in the test code. The patches currently up on mozreview are looking good so far on try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=a8ab96666774e9f6215bdca025e23f372098d620
Assignee: nobody → pehrson
Status: NEW → ASSIGNED
Flags: needinfo?(pehrson)
Attachment #8866772 - Flags: review?(florian)
Attachment #8866773 - Flags: review?(florian)
Comment on attachment 8866772 [details]
Bug 1363253 - Re-enable tests disabled due to gum events.

https://reviewboard.mozilla.org/r/138382/#review142644

This patch doesn't do what it's commit message says.
Attachment #8866772 - Flags: review?(florian) → review-
Comment on attachment 8866773 [details]
Bug 1363253 - Ignore events specific to preview window also when decrementing.

https://reviewboard.mozilla.org/r/138384/#review142650

Great catch, thanks!
Attachment #8866773 - Flags: review?(florian) → review+
Comment on attachment 8866772 [details]
Bug 1363253 - Re-enable tests disabled due to gum events.

https://reviewboard.mozilla.org/r/138382/#review142644

Ah, I started on this before bug 1320994 landed and after a rebase this patch was basically moot.
Attachment #8866772 - Attachment is obsolete: true
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e7c7370fdd54
Ignore events specific to preview window also when decrementing. r=florian
https://hg.mozilla.org/mozilla-central/rev/e7c7370fdd54
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
IIUC, this depends on bug 1320994 (which I assume is a bit risky for uplift)? So Fx54 is wontfix?
Flags: needinfo?(pehrson)
I cannot say for sure if this is dependent on bug 1320994. They're separate issues but without bug 1320994 this could perhaps cause other intermittent fallout. It could be worth trying. And this is test-only so it doesn't affect the product, just the intermittents.
Flags: needinfo?(pehrson)
Duplicate of this bug: 1324303
Duplicate of this bug: 1338038
You need to log in before you can comment on or make changes to this bug.