Closed Bug 1363669 Opened 3 years ago Closed 3 years ago

mastodon.social - video doesn't play

Categories

(Core :: Audio/Video: Playback, defect, P1)

All
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: ayang, Assigned: ayang)

References

Details

(Keywords: compat, testcase-wanted)

Attachments

(3 files)

https://github.com/webcompat/web-bugs/issues/6582


URL: https://mastodon.social/@theoutrider/5375418
Browser / Version: Firefox 55.0
Operating System: Linux
Problem type: Video doesn't play

Steps to Reproduce

    Navigate to: https://mastodon.social/@theoutrider/5375418
    Play video

Expected Behavior:

Video plays

Actual Behavior:

Media error

Technical Information:
Error Code: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c)
Details: virtual RefPtr<mozilla::MozPromise<mozilla::MediaResult, mozilla::MediaResult, true> > mozilla::MP4Demuxer::Init(): No MP4 audio (NS_ERROR_DOM_MEDIA_METADATA_ERR (0x806e0006) - mp4_demuxer::MP4Metadata::ResultAndTrackCount mp4_demuxer::MP4MetadataRust::GetNumberTracks(mozilla::TrackInfo::TrackType) const: Rust parser error 1) or video (NS_ERROR_DOM_MEDIA_METADATA_ERR (0x806e0006) - mp4_demuxer::MP4Metadata::ResultAndTrackCount mp4_demuxer::MP4MetadataRust::GetNumberTracks(mozilla::TrackInfo::TrackType) const: Rust parser error 1) tracks
Resource: https://files.mastodon.social/media_attachments/files/000/429/586/original/e7ccbd1174e15a2a.mp4

From webcompat.com with ❤️
Assignee: nobody → ayang
Blocks: 1161350
Priority: -- → P1
OS: Unspecified → Linux
Hardware: Unspecified → All
Stream #0:0(eng): Video: mpeg4 (Simple Profile) (mp4v / 0x7634706D), yuv420p, 720x480 [SAR 1:1 DAR 3:2], 6044 kb/s, 30 fps, 30 tbr, 90k tbn, 60 tb

video data is encoded in mpeg4 which Firefox doesn't support by design and Chrome doesn't support it either, so close this bug as invalid.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
Although ff doesn't support mp4v (14496-2), mp4 rust parser needs to retrieve the metadata correctly.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Assertion at:

Process 88060 stopped
* thread #76, name = 'MediaPD~oder #1', stop reason = EXC_BAD_ACCESS (code=1, address=0x0)
    frame #0: 0x0000000101c8ce24 XUL`mp4_demuxer::MP4Metadata::GetTrackInfo(this=0x00007000050b4478, aType=kVideoTrack, aTrackNumber=0) const at MP4Metadata.cpp:490
   487 	      MOZ_DIAGNOSTIC_ASSERT(*videoRust->mExtraData == *video->mExtraData);
   488 	      // mCodecSpecificConfig is for video/mp4-es, not video/avc. Since video/mp4-es
   489 	      // is supported on b2g only, it could be removed from TrackInfo.
-> 490 	      MOZ_DIAGNOSTIC_ASSERT(*videoRust->mCodecSpecificConfig == *video->mCodecSpecificConfig);
   491 	      break;
   492 	    }
   493 	    default:
(lldb)


It's due to mCodecSpecificConfig mismatch which is for b2g only on bug 1153876. Since b2g is removed from codes, this can be removed too.
See Also: → 1365872
Comment on attachment 8870316 [details]
Bug 1363669 - add 'mp4v' mimetype for rust parser.

https://reviewboard.mozilla.org/r/141782/#review145712
Attachment #8870316 - Flags: review?(kinetik) → review+
Comment on attachment 8871203 [details]
Bug 1363669 - update rust mp4 parser for mp4v.

https://reviewboard.mozilla.org/r/142694/#review146364
Attachment #8871203 - Flags: review?(kinetik) → review+
Pushed by ayang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/be3f9be99903
add 'mp4v' mimetype for rust parser. r=kinetik
https://hg.mozilla.org/integration/autoland/rev/92c5898618c2
update rust mp4 parser for mp4v. r=kinetik
hmm...

test_case_1181215.mp4 in gtest is a 'mp4v' video which parser doesn't support before. So the output result is different comparing to the origin expectation. We need to update the rust test result in TestParser.
Comment on attachment 8871652 [details]
Bug 1363669 - update gtest about 'mp4v' video parsing.

https://reviewboard.mozilla.org/r/143170/#review147182
Attachment #8871652 - Flags: review?(kinetik) → review+
Pushed by ayang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa4b5a89201b
add 'mp4v' mimetype for rust parser. r=kinetik
https://hg.mozilla.org/integration/autoland/rev/17a953825a4e
update rust mp4 parser for mp4v. r=kinetik
https://hg.mozilla.org/integration/autoland/rev/54d7b5816adb
update gtest about 'mp4v' video parsing. r=kinetik
https://hg.mozilla.org/mozilla-central/rev/fa4b5a89201b
https://hg.mozilla.org/mozilla-central/rev/17a953825a4e
https://hg.mozilla.org/mozilla-central/rev/54d7b5816adb
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
There's much more in the 2nd commit than adding support for mp4v video. It seems to add support for the new vpcc box used for VP9 in MP4. 

Shouldn't this be linked to bug 1310293?
Flags: needinfo?(ayang)
Sorry that's bug 1363669
Flags: needinfo?(ayang)
See Also: → 1365787
You need to log in before you can comment on or make changes to this bug.