Detach the back and forward buttons from the location bar

VERIFIED FIXED in Firefox 55

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

Trunk
Firefox 55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 verified)

Details

(Whiteboard: [photon-visual][p1])

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

2 years ago
Summary: Visually detach the back button from the location bar → Detach the back and forward buttons from the location bar
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Flags: qe-verify+
Priority: -- → P1
Iteration: --- → 55.5 - May 15
QA Contact: brindusa.tot

Comment 2

2 years ago
mozreview-review
Comment on attachment 8866475 [details]
Bug 1363840 - Detach the back and forward buttons from the location bar.

https://reviewboard.mozilla.org/r/138104/#review141320

At least in OSX we can make the forward button look a bit nicer by disabling shorlander's recent changes: https://searchfox.org/mozilla-central/rev/d66b9f27d5630a90b2fce4d70d4e9050f43df9b4/browser/themes/osx/browser.css#579

And in compact theme we should disable the forward button and urlbar borders:
https://searchfox.org/mozilla-central/source/browser/themes/shared/compacttheme.inc.css#209
https://searchfox.org/mozilla-central/source/browser/themes/shared/compacttheme.inc.css#262
Attachment #8866475 - Flags: review?(jhofmann)
Comment hidden (mozreview-request)
(Assignee)

Comment 4

2 years ago
Compact themes still don't seem perfect with MOZ_PHOTON_THEME, but I don't think we need to spend more time on this now since this stuff will change drastically anyway.

Comment 5

2 years ago
mozreview-review
Comment on attachment 8866475 [details]
Bug 1363840 - Detach the back and forward buttons from the location bar.

https://reviewboard.mozilla.org/r/138104/#review141334

I agree, those were just the most visible things. Want to avoid followup discussions :)
Attachment #8866475 - Flags: review?(jhofmann) → review+

Comment 6

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a46c4ea1cf30
Detach the back and forward buttons from the location bar. r=johannh

Comment 7

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/83478ac51418
followup: fix browser_formless_submit_chrome.js on CLOSED TREE
https://hg.mozilla.org/mozilla-central/rev/a46c4ea1cf30
https://hg.mozilla.org/mozilla-central/rev/83478ac51418
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Depends on: 1364477

Comment 9

2 years ago
Hi ,
cannot change the position of back/forward button.
After this bug landed it should have been possible right?
(Assignee)

Comment 10

2 years ago
(In reply to jaruvova from comment #9)
> Hi ,
> cannot change the position of back/forward button.
> After this bug landed it should have been possible right?

This was the first step. Bug 1363485 will open up the possibility to move these elements, at least indirectly by moving other elements between these ones.
(Assignee)

Updated

2 years ago
No longer depends on: 1364477

Comment 11

2 years ago
(In reply to Dão Gottwald [::dao] from comment #10)
> (In reply to jaruvova from comment #9)
> > Hi ,
> > cannot change the position of back/forward button.
> > After this bug landed it should have been possible right?
> 
> This was the first step. Bug 1363485 will open up the possibility to move
> these elements, at least indirectly by moving other elements between these
> ones.

oh okay thanks

Updated

2 years ago
Depends on: 1364702
I can see this implemented in Latest Nightly 55.0a1 on Manjaro Linux 17, 64bit

Build ID 	20170513100302
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

[testday-20170513]

Comment 14

2 years ago
This update should have never went live without the ability to put it back where it was, this is horrible now, thanks for ruining my browser experience by adding an unnecessary button in place of the old reload location to copy and email links which you can do easily anyway by simply right clicking and copy for the normal user. Or simple keyboard ctrl+c, this fix provides nothing but annoyance without the ability to put it back where it was, now its just **** me off from the browser ive been using since firebird, moving my reload button to the left side makes me feel like i was put back in the 90s forced to accept **** choices by devs, until this is changed im done with nightly and firefox in general, horrible choice to implement this without a remedy for users.
Comment hidden (advocacy)

Comment 16

2 years ago
you can flag me all you want, doesn't change the fact that the majority of users wont like this change.
I tested this issue on Windows 7, Mac Os X 10.10 and Ubuntu 16.04 with FF Nightly 55.0a1(2017-06-11) and I can confirm the fix.
Status: RESOLVED → VERIFIED
status-firefox55: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.