Port bug 1356826 to TB: Various visual glitches on Daily starting 2017-05-14 due to Default theme not loaded

RESOLVED FIXED in Thunderbird 55.0

Status

Thunderbird
General
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: Jorg K (GMT+1) [currently bustage-fix only, no NI? or r?], Assigned: Jorg K (GMT+1) [currently bustage-fix only, no NI? or r?])

Tracking

Trunk
Thunderbird 55.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Created attachment 8867565 [details]
visual glitches.png - Screenshot showing the problem

See enclosed screenshot from Windows 7:
- Funny icons
- tab close button wrong
- wrong menu background.

M-C last good (according to Richard): 3a801856dea9
M-C first bad: 626efff0df63

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3a801856dea9&tochange=626efff0df63

Maybe Alice can bisect this for us a bit.
Flags: needinfo?(alice0775)
The icons on the compose window look like Linux icons to me. So, as Richard said in a PM, default theme missing or perhaps OS not detected.

Comment 2

6 months ago
I could not bisect without build. Because there are no c-c build in http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/ .
Flags: needinfo?(alice0775)
(In reply to Jorg K (GMT+2) from comment #1)
> The icons on the compose window look like Linux icons to me. So, as Richard
> said in a PM, default theme missing or perhaps OS not detected.

Do you have an other theme installed but not as the active? And can you check if the default theme is shown in Add-on manager?

On Win 10 on active tabs the rounded tab start and -end aren't shown. Also are icons missing which have overrides in theme.
Yes, I had the Softmaker Theme installed but not active. It provides those Linux/XP-looking icons. No default theme shown in the add-on manager under appearance. Removing the Softmaker theme brings the normal icons back, but two glitches remain:
- tab close button wrong
- wrong menu background.
I think we need to bisect this ourselves. M-C 3a801856dea9 confirmed working, next trying M-C f67316c8b3d5.

Comment 6

6 months ago
(In reply to Jorg K (GMT+2) from comment #5)
> I think we need to bisect this ourselves. M-C 3a801856dea9 confirmed
> working, next trying M-C f67316c8b3d5.

WIP, via local build win32,
Good: 9730f88bdbd3
Bad: 5d4a586ccc42
Created attachment 8867764 [details]
mac-glitch.png

It's not only Windows. This shows how today Daily looks on Mac.
Summary: Various visual glitches on Windows starting 2017-05-14 → Various visual glitches on Daily starting 2017-05-14
Thanks, Alice, my local build based on M-C rev f67316c8b3d5 failed anyway.

No idea why this link doesn't work:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9730f88bdbd3&tochange=5d4a586ccc42

Anyway, the range includes bug 1361900 and bug 1356826. The former got backed out, so I'll try rev 4c35b4cb9a31 now.
Bug 1364878 is also for extensions issues (they stopped the updates for FX). But it doesn't fix it for me. I still think our problems comes from bug 1356826 or bug 1358846.

Comment 10

6 months ago
WIP,
Bad: 0b38ac21c7a5
Bad: 4c35b4cb9a31
OK, bad at M-C rev 4c35b4cb9a31. So it wasn't bug 1361900 since it was backed out at that rev.

Kris, in the range from M-C rev 9730f88bdbd3 to 0b38ac21c7a5 you landed bug 1356826 and bug 1358846. In Thunderbird, the Default theme has disappeared from the Add-ons Manager/Appearance and we see a few visual glitches. I also had a case where a non-active theme was (partly?) used.

Can you give us any hints?
Kris, please see comment 11.
Flags: needinfo?(kmaglione+bmo)
I would imagine it has something to do with this removal:

https://hg.mozilla.org/mozilla-central/rev/b21481adbdca#l44.210
Flags: needinfo?(kmaglione+bmo)
So Richard, can we port bug 1358846? You you have an idea what needs to be done here? Or do we need to ask more questions?
I'm sorry, I don't know at all what needs porting of bug 1358846. All changes are in toolkit. What is different in TB to FX? This is why I thought bug 1356826 could be the problem. It has changes in browser too.
So Kris, what do we need to do to get our theme back on track? Can you please give us some more hints.
Flags: needinfo?(kmaglione+bmo)
The browser/ are only for scans for side-loaded add-ons after startup is complete.

I don't know enough about Thunderbird to say what other problems there might be. A log of the startup output with the extensions.logging.enabled pref set might help.
Flags: needinfo?(kmaglione+bmo)

Comment 18

6 months ago
Via local build,
Last Good:  c-c b10f2ed8847b, m-c f67316c8b3d5 and backed out Bug 1361900 Part1-10
First Bad:  c-c b10f2ed8847b, m-c 6bc3416bc56e and backed out Bug 1361900 Part1-10

Regressed by: Bug 1356826
Great job, Alice, much appreciated!!

Adding this to all-thunderbird.js
  pref("extensions.startupScanScopes", 15);
fixes the following:
- tab close button now correct
- Default theme back in add-on manager.
Not fixed:
- wrong menu background.

Kris, sorry to trouble you again, can you please tell us something about the preference.
Flags: needinfo?(kmaglione+bmo)
This, right?
http://searchfox.org/mozilla-central/rev/ae24a3c83d22e0e35aecfd9049c2b463ca7e045b/toolkit/mozapps/extensions/AddonManager.jsm#3397
  // General descriptions of where items are installed.
  // Installed in this profile.
  SCOPE_PROFILE: 1,
  // Installed for all of this user's profiles.
  SCOPE_USER: 2,
  // Installed and owned by the application.
  SCOPE_APPLICATION: 4,
  // Installed for all users of the computer.
  SCOPE_SYSTEM: 8,
and more.
So 15 is the sum of all of the above. Maybe we can do with less, maybe 4. Yep,
  pref("extensions.startupScanScopes", 4);
works.
Summary: Various visual glitches on Daily starting 2017-05-14 → Port bug 1356826 to TB: Various visual glitches on Daily starting 2017-05-14 due to Default theme not loaded
Created attachment 8867916 [details] [diff] [review]
1364787-default-theme.patch

OK, that fixes some problems, maybe the load is still too late for the menu background to be right.
Attachment #8867916 - Flags: review?(richard.marti)
Attachment #8867916 - Flags: feedback?(kmaglione+bmo)
Attachment #8867916 - Flags: feedback?(kmaglione+bmo) → feedback+
https://hg.mozilla.org/comm-central/rev/144df04bc9fc1dc5c4e94f4a9283d4e67c52dc25

Landed this for now as a bustage-fix, we can follow up later. Richard, can you please investigate why the menu background isn't correct.
Flags: needinfo?(kmaglione+bmo)
Duplicate of this bug: 1365134
Comment on attachment 8867916 [details] [diff] [review]
1364787-default-theme.patch

I can't test it now but it seems reasonable and Kris gave an f+
Attachment #8867916 - Flags: review?(richard.marti) → review+
Assigning this to Richard so he can look into the menu background. Also, there is bug 1365134 and we might have to increase the pref value to 7.
Assignee: nobody → richard.marti

Comment 26

6 months ago
(FYI, I cannot reproduce the menu background problem on windows7 with new profile.)
Thanks Alice, I can confirm that the menu background is OK on a new profile and also on the existing profile after cleaning out some junk.

I think we're done here. Repeating landing:
https://hg.mozilla.org/comm-central/rev/144df04bc9fc1dc5c4e94f4a9283d4e67c52dc25 (comment #22).
Assignee: richard.marti → jorgk
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0
And a *BIG* **HUGE** THANK YOU(!!!) to Alice for his invaluable help. We'd really be struggling without you.
You need to log in before you can comment on or make changes to this bug.