All extensions are force enabled and marked as disabled in about:addons & about:support after landing patches from bug #1358846

VERIFIED FIXED in Firefox 55

Status

()

defect
--
major
VERIFIED FIXED
2 years ago
2 days ago

People

(Reporter: Virtual, Assigned: kmag)

Tracking

(Blocks 1 bug, {nightly-community, regression})

55 Branch
mozilla55
x86_64
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55+ verified)

Details

Attachments

(1 attachment)

[Tracking Requested - why for this release]: Regression


STR:
1. Update Mozilla Firefox Nightly 55.0a1 to (2017-05-15) build from (2017-05-14) build
2. Open about:addons or about:support
3. See that all extensions are force enabled and marked as disabled
Looking on regression range, I suspect that this issue is probably caused by:
Bug #1356826 - Get rid of directory scans, and especially recursive directory scan, at startup
Blocks: 1356826
Component: Untriaged → Add-ons Manager
Flags: needinfo?(kmaglione+bmo)
Product: Firefox → Toolkit
Bug #1361900 - Use script precompiler in content processes
could be other cause.
Blocks: 1361900

Comment 4

2 years ago
In my case, after re-enabling / re-disabling most of my extensions, I can no longer disable those extensions that are marked as not multiprocess compatible. It is because there was no "enable" button to begin with for these extensions when e10s is enabled.
Also, NoScript cannot be disabled even if I explicitly try to disable it a few times.
(In reply to Fanolian from comment #4)
> Also, NoScript cannot be disabled even if I explicitly try to disable it a
> few times.

The same problem occurs with Greasemonkey.
Tracking 55+ for this issue.
I disabled nightly updates for now until we find the last good last build to point users to. Will send an email to r-d in a bit.

Comment 8

2 years ago
(In reply to Marco Castelluccio [:marco] from comment #5)
> (In reply to Fanolian from comment #4)
> > Also, NoScript cannot be disabled even if I explicitly try to disable it a
> > few times.
> 
> The same problem occurs with Greasemonkey.

Same problem with Tab Mix Plus and Yet Another Smooth Scrolling. However, I can enable or disable AdBlock Plus, uBlock Origin and Session Manager. It looks like all e10s-compatible non-jetpack addons can't disabled.
There are a bunch of these messages during startup:
Disabling foreign installed add-on {72b2e02b-3a71-4895-886c-fd12ebe36ba3} in app-profile
ie, extensions are being erroneously marked as having been sideloaded.

My money is on bug 1358846.  I haven't looked at those patches, they are enormous.  But this would be consistent with not propagating the bit for sideloaded addons while migrating.
Assignee

Updated

2 years ago
No longer blocks: 1361900
Flags: needinfo?(kmaglione+bmo)
Kris, could you confirm that the patch in bug 1358846 are the ones that caused this bug?
Flags: needinfo?(kmaglione+bmo)
Comment hidden (mozreview-request)
Attachment #8867773 - Flags: review?(aswan) → review?(rhelmer)

Comment 12

2 years ago
mozreview-review
Comment on attachment 8867773 [details]
Bug 1364878: Fix add-on path migration issues.

https://reviewboard.mozilla.org/r/139310/#review142608

Do we need to bump the schema version too?
Attachment #8867773 - Flags: review?(rhelmer) → review+
Can we write a test for this?
Flags: in-testsuite?
Assignee

Comment 15

2 years ago
I'm looking into it, but we don't have any good tools for writing DB migration tests, so I'm going to do it as a follow-up.
Flags: needinfo?(kmaglione+bmo)
Assignee: nobody → kmaglione+bmo
Blocks: 1358846
Status: NEW → ASSIGNED
Has Regression Range: --- → yes

Comment 16

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1e803c515c7a
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55

Updated

2 years ago
No longer blocks: 1356826
FYI - The followup is being tracked in the bug #1365256, as the issue wasn't fixed completely.
Updates for Nightly are now re-enabled.
Linux updates weren't working until just now, see bug 1365508.
We spot-checked a few update flows from May 14 and May 15 Nightly build, to latest Nightly build, across platforms and some of the most popular locales. Checking that a handful of add-ons work as expected after the update was also part of our test coverage.

Apart from Bug 1364934, which we encountered consistently on macOS 10.12.4 using Nightly builds from May 15+, all of our tests passed.

Detailed test results are available in this etherpad [1], while the broken scenarios we identified as affected by Bug 1364934 have been listed in that bug.


[1] https://public.etherpad-mozilla.org/p/1364878-sv

Updated

2 years ago
Blocks: 1365706
Assignee

Updated

2 years ago
Blocks: 1365717
I'm confirming that this issue is fixed, starting from Mozilla Firefox Nightly 55.0a1 (2017-05-18) [with followups: bug #1365256 and bug #1365706].
Status: RESOLVED → VERIFIED
Summary: All extensions are force enabled and marked as disabled in about:addons & about:support in Mozilla Firefox Nightly 55.0a1 (2017-05-15) → All extensions are force enabled and marked as disabled in about:addons & about:support after landing patches from bug #1358846
And probably follow-up bug 1365568
Duplicate of this bug: 1365640
You need to log in before you can comment on or make changes to this bug.