Sidebar header has a dark background and dark text with the dark compact theme installed (win10)

VERIFIED FIXED in Firefox 55

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: alex_mayorga, Assigned: bgrins)

Tracking

(Blocks 1 bug, {nightly-community})

55 Branch
Firefox 55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed, firefox56 verified)

Details

(Whiteboard: [photon-structure])

Attachments

(2 attachments)

¡Hola!

The sidebar header switcher from https://bugzilla.mozilla.org/show_bug.cgi?id=1355324 is is almost impossible to read when using the dark theme, see https://bugzilla.mozilla.org/attachment.cgi?id=8868634

¡Gracias!
Alex
I can confirm this behaviour using the Dark Fox theme. When I hover the URL bar, it becomes grey and hard to read.
Hi Alex, what operating system are you seeing this on?
Flags: needinfo?(alex_mayorga)
¡Hola Brian!

This is on Windows 10.

¡Gracias!
Alex
Flags: needinfo?(alex_mayorga)
Component: General → Theme
Summary: Heading hard to read when using dark compact theme → Sidebar header has a dark background and dark text with the dark compact theme installed (win10)
Going to make a decision on whether this should be a dark background with light text, or a light background with dark text in https://bugzilla.mozilla.org/show_bug.cgi?id=1365807#c3.
See Also: → 1365807
Whiteboard: [photon-structure]
Whiteboard: [photon-structure] → [photon-structure] [triage]
Based on the decision in Bug 1365807, we are going to change the background to be light instead of making the text light
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [photon-structure] [triage] → [photon-structure]
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment on attachment 8871338 [details]
Bug 1365705 - Remove Windows compact theme specific styling for sidebar;

https://reviewboard.mozilla.org/r/142816/#review146842
Attachment #8871338 - Flags: review?(dao+bmo) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a7c7fd053fa3
Remove Windows compact theme specific styling for sidebar;r=dao
https://hg.mozilla.org/mozilla-central/rev/a7c7fd053fa3
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Iteration: --- → 55.6 - May 29
I have reproduced this bug with Nightly 55.0a1 (2017-05-17) on Windows 8 (64 bit).

This bug's fix is verified on Latest Nightly 55.0a1.


Build ID : 20170608030205
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170607]
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I'm still seeing this issue with the following user agents:
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

The text with Bookmarks sidebar is still dark and hard to read with the Dark Compact theme installed via the Customize window. Screenshot attached.
Hi Grover,

Can you check if this was fixed on those platforms in the first nightly this landed in, probably 2017-05-27 ? I suspect this regressed because of bug 1367242. If the patch worked originally, I guess it might be helpful to have a new bug to fix this a second time, as in that case the original fix would still be on 55 beta and working there (which would be good to doublecheck, too).
Flags: needinfo?(gwimberly)
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly
Iteration: 55.6 - May 29 → ---
Blocks: 1376109
Filed bug 1376109.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Flags: needinfo?(gwimberly)
Resolution: --- → FIXED
Iteration: --- → 56.1 - Jun 26
Iteration: 56.1 - Jun 26 → 55.6 - May 29
Marking as Verified.
Flags: qe-verify+
Status: RESOLVED → VERIFIED
Blocks: 1387512
You need to log in before you can comment on or make changes to this bug.