sidebar-header has a light background and dark text even with the dark compact theme installed (linux)

RESOLVED WONTFIX

Status

()

defect
--
minor
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: euthanasia_waltz, Unassigned)

Tracking

55 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

On Compact Dark theme, foreground black, background white.
Former, foreground white, background black.
Blocks: 1355324
See Also: → 1365705
Component: General → Theme
Brian, can you please look into this?
Flags: needinfo?(bgrinstead)
Summary: sidebar-header style broken → sidebar-header has a light background and dark text even with the dark compact theme installed (linux)
Here's the situation as best as I can tell before and after the sidebar header changes:

Before the new sidebar header, with the dark compact theme applied:
* Windows: Dark sidebar header with light text
* Linux: Dark sidebar header with light text
* OSX: Sidebar header unchanged

After the new sidebar header, with the dark compact theme applied:
* Windows: Dark sidebar header with dark text (bug 1365705)
* Linux: Light sidebar header with dark text (matching sidebar spec)
* OSX:  Light sidebar header with dark text (matching sidebar spec)

We've discussed a more thorough redesign of the entire sidebar contents to match a dark theme, but that'd be a new set of work.  In the meantime, I'm assuming we want to unify the behavior cross-platform so there are two main options:

1) When dark compact theme is installed, have the sidebar header use a dark background / light text (matching 'before' behavior on windows / linux)
2) When dark compact theme is installed, leave the sidebar header unchanged light background / dark text (matching the photon spec and current OSX / linux behavior)

If/when we restyled the sidebar contents to be dark we will certainly want to have (1), but what do you prefer it looks like in the meantime?
Flags: needinfo?(bgrinstead) → needinfo?(abenson)
I think we should address a dark sidebar theme holistically and not introduce a dark header with "light" contents.
Flags: needinfo?(abenson)
Whiteboard: [photon-structure]
Whiteboard: [photon-structure] → [photon-structure] [triage]
(In reply to Aaron Benson from comment #4)
> I think we should address a dark sidebar theme holistically and not
> introduce a dark header with "light" contents.

OK, so sounds like for now we will stick with the light background / dark text.  Once the sidebar contents is styled appropriately for the dark theme we'll update the header to match
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Whiteboard: [photon-structure] [triage]
Cross-linking to Bug 1329242 -- on macOS right now I have a dark compact theme with a mid-grey "Tabs" bar and a bright white Tab Center Redux. If I edit the TCR CSS, I get a dark toolbar with a visually bright grey "Tabs" and dark Tab Center. :/
See Also: → 1329242
:bgrins "wontfix" doesn't equal "this will be done once we style the sidebar in the dark theme"
Is there a bug report, I can follow, that tracks the progress of styling sidebars for the dark theme?

Addons like tree style tab already bring stylesheets with them that allow a dark theme.
The only thing remaining is the white sidebar title. (see screenshot: "treestyle.png")

For now my workaround is to use userChrome.css to make the title invisible, so this isn't to big of an issue for me.
I would still like to follow a related bug report though :)

Regards,
Djfe
Posted image treestyle.png
(In reply to Djfe from comment #7)
> Is there a bug report, I can follow, that tracks the progress of styling
> sidebars for the dark theme?

Yes, you can track this at Bug 1385518
See Also: → 1385518
You need to log in before you can comment on or make changes to this bug.