Fix about:telemetry data preferences change button

RESOLVED FIXED in Firefox 55

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: gfritzsche, Assigned: flyingrub)

Tracking

(Blocks 1 bug)

Trunk
mozilla55
Points:
1
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

The preferences layout changed recently, breaking the "change" buttons for the data controls.

Helpful bit of info from bug 1022013:

(In reply to Jared Wein [:jaws] (behind on reviews and bugmail) (please needinfo? me) from bug 1022013, comment #6)
> Clicking on "Telemetry Settings" should go to
> about:preferences#privacy-reports.
> 
> The "-reports" part will filter the page to only show the telemetry-related
> prefs.
Reporter

Updated

2 years ago
Priority: P2 → P1

Updated

2 years ago
Assignee: nobody → flyinggrub
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8874387 [details]
Bug 1366978 - Fix about:telemetry data preferences change button

https://reviewboard.mozilla.org/r/145742/#review149728

This is a sensible, contained change that should make it into 55 (since that's where the preferences changes are introduced)
Attachment #8874387 - Flags: review?(chutten) → review+
Assignee

Updated

2 years ago
Keywords: checkin-needed

Comment 3

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a8c405fb767d
Fix about:telemetry data preferences change button r=chutten
Keywords: checkin-needed

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a8c405fb767d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55

Updated

2 years ago
Duplicate of this bug: 1371090
Assignee

Updated

2 years ago
Blocks: 1373823
Reporter

Updated

2 years ago
Blocks: 1384534
You need to log in before you can comment on or make changes to this bug.