set up a prototype OS X 10.10 build machine

RESOLVED FIXED

Status

Infrastructure & Operations
RelOps
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: arr, Assigned: dividehex)

Tracking

Details

(Reporter)

Description

8 months ago
We're going to try installing 10.10 on a builder to see if that's a feasible build platform and might solve our stylo issues.

To make puppet life easy, we'll call it bld-yosemite-r5.build.releng.scl3.mozilla.com
(Reporter)

Comment 1

8 months ago
Actually, we're going to put it in try:
bld-yosemite-r5.try.releng.scl3.mozilla.com
(Reporter)

Comment 2

8 months ago
Retasked bld-lion-r5-096.try.releng.scl3.mozilla.com as bld-yosemite-r5-001.try.releng.scl3.mozilla.com in inventory https://inventory.mozilla.org/en-US/systems/show/6708/
Commented out in nagios.

Jake is going to try modify the DS server to serve up the 10.10 image today.

Updated

8 months ago
Blocks: 1368144
Thanks Amy, Coop.
(Reporter)

Comment 4

8 months ago
We had packages built for 10.7 for the following that did not exist for 10.10. For the first pass of this prototype (for the sake of speed), we're just copying them over from /data/repos/DMGs/10.7 to the /data/repos/DMGs/10.10 deployment directory to see if they will function on 10.10.

autoconf-2.13.dmg 
ccache-3.1.7.dmg
libpng-1.6.2.dmg  
p7zip-9.20.1.dmg 
upx-3.05.dmg 
yasm-1.3.0.dmg 

We also need xcode. Again for the sake of speed, we're grabbing 56841_xcode_6.1.dmg from https://developer.apple.com/download/more/, since it matches the version of the command line tools we're installing on 10.10. This is at /data/repos/private/DMGs/xcode-6.1.dmg
(Reporter)

Comment 5

8 months ago
I've installed xcode 6.1 by hand from the GUI (instead of through puppet) and run
xcodebuild -license accept

I've followed the loaner instructions at: https://wiki.mozilla.org/ReleaseEngineering/How_To/Loan_a_Slave to change the password and wipe out sensitive data.

:rillian, would you be the appropriate person to give this a first pass? If so, I can give you the username/pw pair and you should be able to screen share to the host if you disconnect and reconnect to the VPN using your mozilla credentials.

There might be some rough edges since we are (with the exception of xcode) using the same automation and packages as we did for 10.7. If there are changes required, we can work on those when you confirm we have a working build that has the appropriate backward/forward binary comparability.
Flags: needinfo?(giles)
(Reporter)

Comment 6

8 months ago
Gave access credentials to :rillian on Friday, and he was able to complete a build. The issue with stylo was also cleared up in code, so an upgrade may not be necessary. If it's deemed that we do need an upgrade, I think that the one thing that requires modification is the automated installation of Xcode.

Going to marked this as resolved and will ask for new bugs if we decide to move ahead with an upgrade across the board instead of focusing on the cross compiling solution.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(giles)
Resolution: --- → FIXED

Comment 7

8 months ago
(In reply to Amy Rich [:arr] [:arich] from comment #6) 
> Going to marked this as resolved and will ask for new bugs if we decide to
> move ahead with an upgrade across the board instead of focusing on the cross
> compiling solution.

I confirmed this in the Quantum mtg today. Thanks, Amy.
You need to log in before you can comment on or make changes to this bug.