Closed Bug 1369253 Opened 5 years ago Closed 5 years ago

Intermittent dom/base/test/test_intersectionobserver_no_root.html | undefined assertion name - got "0,0,0,0,0,0,1280,915", expected true

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox54 --- unaffected
firefox55 --- disabled
firefox56 --- disabled

People

(Reporter: intermittent-bug-filer, Assigned: tschneider)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell disabled])

Attachments

(1 file, 2 obsolete files)

Tobias, can you please take a look?
Flags: needinfo?(tschneider)
On it.
Flags: needinfo?(tschneider)
we have 73 failures in the last week, 44 the week prior, this is primarily on win/opt non-e10s tests.

:tobytailer, I see a couple weeks ago you started looking into this- do you need more information?  With the increased failures I would like to see a resolution this week (fix, reduction, disabling)
Flags: needinfo?(tschneider)
Whiteboard: [stockwell needswork]
I'm gonna focus on this to have a solution this week.
Flags: needinfo?(tschneider)
Assignee: nobody → tschneider
I wasn't able to reproduce the failures locally but I think I'm having a good idea why it fails. I would love to land a slightly changed test first and leave it in the three for a short while to gather a bit more information the next time it fails. I will provide a final fix once that additional information confirms my idea.
Attachment #8879363 - Flags: review?(jmaher)
Attachment #8879363 - Flags: review?(jmaher) → review+
Pushed by tschneider@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f5ad2f825cc5
Gather more information when test fails. r=jmaher
Under some circumstances we test for intersection when the window was not fully loaded. Make sure we wait for onload event.
Attachment #8879363 - Attachment is obsolete: true
Attachment #8879363 - Attachment is obsolete: false
Attachment #8880862 - Flags: review?(jmaher)
Comment on attachment 8880862 [details] [diff] [review]
Make sure window is fully loaded before testing intersection

Review of attachment 8880862 [details] [diff] [review]:
-----------------------------------------------------------------

this looks good, thanks for fixing this!
Attachment #8880862 - Flags: review?(jmaher) → review+
I tested this a bit more and it turned out the intermittent failures still occur. This is a pretty fragile test, it always was. This was our first test we had for testing exact root bounds used for intersection calculation. The reason we run this test in a separate window is to avoid it running in an iframe, as it might be the case when running via the mochitest harness. But this is also the reason why this test is so unstable, especially on slower machines. Meanwhile we have way better test coverage for this landed via https://bugzilla.mozilla.org/show_bug.cgi?id=1358666. Therefore I would like to disable this test as it will probably keep causing problems. Joel, any thoughts on this?
Flags: needinfo?(jmaher)
given the fact that there is a newer test that covers the same things, this sounds like a duplicate test and I would have no worries about disabling it.
Flags: needinfo?(jmaher)
Attached patch Disable testSplinter Review
As discussed, disabling this test for being redundant and highly unstable. We have create coverage for this test case landed via Bug 1358666.
Attachment #8879363 - Attachment is obsolete: true
Attachment #8880862 - Attachment is obsolete: true
Attachment #8881160 - Flags: review?(jmaher)
Comment on attachment 8881160 [details] [diff] [review]
Disable test

Review of attachment 8881160 [details] [diff] [review]:
-----------------------------------------------------------------

looks good!
Attachment #8881160 - Flags: review?(jmaher) → review+
Pushed by tschneider@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9286413c8215
Disable redundant dom/base/test/test_intersectionobserver_no_root.html on all platforms. r=jmaher
Whiteboard: [stockwell needswork] → [stockwell disabled]
We disabled this test in Bug 1369253.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
It sounds like we have no intention of fixing this test, so why was it disabled instead of being removed outright?

https://hg.mozilla.org/releases/mozilla-beta/rev/2c41c817d86a
Flags: needinfo?(tschneider)
I will create a separate bug to remove this test entirely.
Flags: needinfo?(tschneider)
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.