Last Comment Bug 137007 - add "Send Link" to link context menus
: add "Send Link" to link context menus
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: UI Design (show other bugs)
: Trunk
: All All
: -- enhancement with 3 votes (vote)
: ---
Assigned To: Vlado Valastiak [:wladow] @ Mozilla.sk
:
Mentors:
http://mozilla.org/projects/ui/commun...
: 139835 165627 416613 (view as bug list)
Depends on:
Blocks: 135841
  Show dependency treegraph
 
Reported: 2002-04-11 17:20 PDT by sairuh (rarely reading bugmail)
Modified: 2008-07-31 04:16 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1 (3.46 KB, patch)
2008-07-02 04:09 PDT, Vlado Valastiak [:wladow] @ Mozilla.sk
neil: review-
Details | Diff | Review
v2 (3.80 KB, patch)
2008-07-10 02:28 PDT, Vlado Valastiak [:wladow] @ Mozilla.sk
no flags Details | Diff | Review
v3 (4.03 KB, patch)
2008-07-10 05:21 PDT, Vlado Valastiak [:wladow] @ Mozilla.sk
neil: review+
neil: superreview+
Details | Diff | Review

Description sairuh (rarely reading bugmail) 2002-04-11 17:20:21 PDT
(filing rfe's for proposed/unimplemented browser context menus, based on
Marlon's spec.)

add "Open Link" to the link as text link and image as link context menus.
Comment 1 sairuh (rarely reading bugmail) 2002-04-11 17:34:31 PDT
add "Send Link" to the same menus (might as well combine here since they both
appear in them in the spec).
Comment 2 Jürgen Nagel 2002-04-21 07:19:35 PDT
The Send Link entry was removed when Mozilla's menus were cleaned up.
Please re-add it ASAP. It was very useful.
Comment 3 Jesse Ruderman 2002-04-26 22:15:33 PDT
Open Link is bug 64749, Send Link is bug 139835.

*** This bug has been marked as a duplicate of 64749 ***
Comment 4 sairuh (rarely reading bugmail) 2002-04-26 22:35:18 PDT
reopening. i filed this after discussion with marlon. we know that Send Link was
removed for the current context menu implementation, but the latest version of
his spec asks to bring it back.

thanks for finding bug 64749, however --will add that to the dependency list of
bug 135841 as well.
Comment 5 Jesse Ruderman 2002-05-06 18:46:08 PDT
*** Bug 139835 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Wang 2002-08-30 01:26:15 PDT
*** Bug 165627 has been marked as a duplicate of this bug. ***
Comment 7 Robert La Ferla 2003-05-29 17:02:27 PDT
I think this is useful and needed functionality.  Being able to right-click on a
link and send it is something that is handy.
Comment 8 Aaron Kaluszka 2003-08-14 10:36:27 PDT
Firebird has this now (bug 173954).
Comment 9 Blake Ross 2004-04-03 15:22:00 PST
Reassigning obsolete bugs to their respective Seamonkey owners (i.e. nobody). 
If you want this fixed for Firefox, change the Product and Component accordingly
and reassign back to me.
Comment 10 Wayne Mery (:wsmwk, NI for questions) 2007-08-20 06:10:32 PDT
bump
Comment 11 Serge Gautherie (:sgautherie) 2008-06-10 09:58:24 PDT
Filter "spam" on "guifeatures-nobody-20080610".
Comment 12 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-07-02 03:08:24 PDT
*** Bug 416613 has been marked as a duplicate of this bug. ***
Comment 13 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-07-02 04:09:01 PDT
Created attachment 327784 [details] [diff] [review]
v1

This patch adds "Send Link" to context menu for saveable links. It means this menu item is shown for several protocols, f.e. mailto: links too. I don't know if mailto: as saveable link is desired but that's not what this bug is about. Maybe follow-up?

Patch uses existing (and updated) sendLink function that is used for File -> Send Link menu item. I'm using a new string for context menu, but with the same wording. Maybe we should reword File -> Send Link to something like "Send link to this page"? Because that's what it is doing.
Comment 14 neil@parkwaycc.co.uk 2008-07-02 09:40:42 PDT
Comment on attachment 327784 [details] [diff] [review]
v1

>+        // Save/send link depends on whether we're in a link.
>+        if (this.onSaveableLink) {
>           goSetMenuValue( "context-savelink", this.autoDownload ? "valueSave" : "valueSaveAs" );
>         this.showItem( "context-savelink", this.onSaveableLink );
>+        this.showItem( "context-sendlink", this.onSaveableLink );
>+        }
This is wrong; the if is only there to avoid upating the "Save Link Target (As)..." label if we're not going to show the menuitem.

> <!ENTITY contextSendPage.label           "Send Page…">
> <!ENTITY contextSendPage.accesskey       "d">
>+<!ENTITY contextSendLink.label           "Send Link…">
>+<!ENTITY contextSendLink.accesskey       "d">
Hmm, I think we need to work out why Send Page doesn't get hidden on links...
Comment 15 neil@parkwaycc.co.uk 2008-07-03 08:53:05 PDT
Comment on attachment 327784 [details] [diff] [review]
v1

> <!ENTITY contextSendPage.label           "Send Page…">
> <!ENTITY contextSendPage.accesskey       "d">
>+<!ENTITY contextSendLink.label           "Send Link…">
>+<!ENTITY contextSendLink.accesskey       "d">
> <!ENTITY contextSendImage.label          "Send Image…">
> <!ENTITY contextSendImage.accesskey      "n">
OK, so Send Page is currently only hidden for a linked image, but this isn't good enough if we want to be able to send link. I also think that the text should be "Send Link Target..." (sorry I'm too lazy to copy and paste a unicode ellipsis)
Comment 16 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-07-07 05:41:42 PDT
(In reply to comment #15)
> (From update of attachment 327784 [details] [diff] [review])
> > <!ENTITY contextSendPage.label           "Send Page…">
> > <!ENTITY contextSendPage.accesskey       "d">
> >+<!ENTITY contextSendLink.label           "Send Link…">
> >+<!ENTITY contextSendLink.accesskey       "d">
> > <!ENTITY contextSendImage.label          "Send Image…">
> > <!ENTITY contextSendImage.accesskey      "n">
> OK, so Send Page is currently only hidden for a linked image, but this isn't
> good enough if we want to be able to send link. I also think that the text
> should be "Send Link Target..." (sorry I'm too lazy to copy and paste a unicode
> ellipsis)
> 
Why do you want to have text "Send Link Target"? Link target means something that you see after clicking on a link. So if this link target is a .zip, "send link target" should send that file etc. We are sending just a link to that file.

Comment 17 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-07-10 02:28:48 PDT
Created attachment 328850 [details] [diff] [review]
v2

Description:
1) use updated SendLink function
2) show Send Link for saveable links
3) hide Send Page in links context menus
4) use "Send This Link" string in context menus
Comment 18 neil@parkwaycc.co.uk 2008-07-10 02:40:05 PDT
(In reply to comment #17)
> 3) hide Send Page in links context menus
The alternative I guess would be to rename it to "Send This Page",
but I'm not sure we have a spare accesskey we can use for it!
Comment 19 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-07-10 05:21:07 PDT
Created attachment 328862 [details] [diff] [review]
v3

OK, let's rename Send Page, "k" is available as accesskey for Send This Link.
Comment 20 neil@parkwaycc.co.uk 2008-07-10 06:43:20 PDT
Comment on attachment 328862 [details] [diff] [review]
v3

>-        if (this.onSaveableLink)
>+        if (this.onSaveableLink) 
This file has far too many trailing spaces as it is ;-)
Comment 21 neil@parkwaycc.co.uk 2008-07-10 06:43:52 PDT
Fix checked in without that one space.

Note You need to log in before you can comment on or make changes to this bug.