drag and drop email message or iCal attachment onto calendar

VERIFIED DUPLICATE of bug 244459

Status

--
enhancement
VERIFIED DUPLICATE of bug 244459
17 years ago
11 years ago

People

(Reporter: danp, Unassigned)

Tracking

Details

(Reporter)

Description

17 years ago
distinguish between 
a. dropping an icalendar attachment from an email on a calendar, and 
b. dropping an email containing an icalendar attachement on a calendar, 

(a) dropping an icalendar attachment on a calendar sub folder selects 
    in which of multiple calendars/categories it is saved 
    (work, personal, per organization/club, per-client/friend, etc.)

However, just including the icalendar info without the rest of the
message loses the context.  Often the icalendar event may not have the
complete information contained in the message (e.g., full description
of the event, commentary about the event, identity of the person
recommending/forwarding it, etc.)

When I see an event in my calendar, I would like to be able to quickly
recover the message that announced the event, and perhaps also any
email discussion that ensued, so I can see if there were any followup
messages for changes of time/place, cancellation, changes of
agenda/todos, discussion of the topic, etc., (at least if my headings
pane is in threaded mode).

(b) dropping an email with an icalendar attachment on a calendar adds
    the event to the calendar with a link to the email.  Clicking on
    the link takes me to the message viewed mail/news, where the the
    message is displayed on the content pane and message header is
    selected in the headings pane.

(c) dropping an email (with/without an icalendar attachment) on an
    event inside a calendar folder adds the link to the email to the
    event.

All three drop events could also be done by dropping onto the calendar
itself, but that may require more screen space than the user would
like to commit while reading mail, particularly if used on a smaller
screen device.

This is from:
news://news.mozilla.org:119/7e192bd5.0204111630.1538d822@posting.google.com

Updated

17 years ago
Blocks: 122651
(Reporter)

Comment 1

17 years ago
setting this to enhancement since that's what it is.
Severity: normal → enhancement

Comment 2

17 years ago
Add:  Dropping an e-mail on a date in the calendar pops up a new appointment
with the following defaults:

- date set to date dropped on

- appointment description set to contents of the e-mail message.


In the future, we might add the following additional defaults to the appointment:

- link back to mail message

- "mailto:" link to the e-mail's "ReplyTo:"

- list of any hyperlinks in the e-mail body


In the future, one of the views could be "Show Links", which will show any links
in the appointments in the calendar.

Updated

15 years ago
Depends on: 244459

Updated

15 years ago
Summary: RFE: drag and drop email message or iCal attachment onto calendar → drag and drop email message or iCal attachment onto calendar

Comment 3

15 years ago
This is similar to what I requested on, #247764.  Being able to drop mozilla
mail onto mozilla calendar and pull up a task or calendar apointment, along with
contact info from the address book if desired.  I don't think linking back to a
mail message is necessary...it may be that the mail message just gets appended
to the schedule item,task (to do), appointment, as a note.

It would also be really usefull to be able to right click on an email have a
context menu come up that would enable a user to add the email to a todo list,
or a calendar event. Or from the address book, right click a contact to add an
appointment or follow up request to a contact that would be posted in the calendar.

This would be really helpful for following up with emails at a later time, or to
add someones request to your task list.

Comment 4

13 years ago
*** Bug 315100 has been marked as a duplicate of this bug. ***

Updated

13 years ago
QA Contact: colint → sunbird

Comment 5

13 years ago
*** Bug 320793 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Assignee: danp → nobody

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 244459
Status: RESOLVED → VERIFIED
No longer depends on: 244459
You need to log in before you can comment on or make changes to this bug.