Closed Bug 1372881 Opened 2 years ago Closed 2 years ago

2.38 - 3.04% sessionrestore / sessionrestore_no_auto_restore / ts_paint (linux64) regression on push 321e5a4f37b5 (Tue Jun 13 2017)

Categories

(Firefox :: Session Restore, defect)

Unspecified
Linux
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: igoldan, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=92a8b8ce2f728ea5cc4ea8e4d8b3e2c5fe76a9ed&tochange=321e5a4f37b543c73055159b9630621890fc8b4e

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  3%  sessionrestore_no_auto_restore linux64 opt e10s     656.08 -> 676.00
  3%  sessionrestore linux64 opt e10s                     629.33 -> 645.83
  2%  ts_paint linux64 opt e10s                           1,069.83 -> 1,095.25


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=7259

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
:florian The patch above resolves multiple bugs. The ones I find more related to these regressions are bug 1372152, bug 1372326 
and bug 1371710. Could you confirm the regressions and point to the right bug?
Flags: needinfo?(florian)
Bug 1372152 is touching Windows-only code, so definitely unrelated.

Bug 1372326 is very likely the cause, as it adds additional instrumentation during startup. This is only for non-release builds (nightly or debug builds), so if that's indeed the cause, this bug is wontfix... unless we find a smart way to make that code run only during mochitests, but not during normal runs or talos runs.
No longer blocks: 1372152
Flags: needinfo?(florian)
(In reply to Florian Quèze [:florian] [:flo] from comment #2)
> Bug 1372152 is touching Windows-only code, so definitely unrelated.
Thanks for pointing this out. This helped me identify the improvement source for sessionrestore and tresize from alert https://treeherder.mozilla.org/perf.html#/alerts?id=7261
Component: Untriaged → Session Restore
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.