Status

enhancement
P3
normal
RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: gl, Assigned: gl)

Tracking

unspecified
Firefox 56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

No description provided.
Comment on attachment 8878309 [details]
Bug 1373492 - Enable the layout viw by default.

https://reviewboard.mozilla.org/r/149654/#review154368

::: commit-message-955e2:1
(Diff revision 1)
> +Bug 1373492 - Enable the layout viw by default. r=pbro

nit: view instead of viw
Attachment #8878309 - Flags: review?(pbrosset) → review+
Will you also post a patch to enable the grid outline here?
Priority: -- → P3
(In reply to Patrick Brosset <:pbro> from comment #3)
> Will you also post a patch to enable the grid outline here?

I enabled the grid outline in Bug 1356474.
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d2ee0638f59
Enable the layout view by default. r=pbro
Backed out for failing browser_inspector_highlighter-eyedropper-xul.js:

https://hg.mozilla.org/integration/mozilla-inbound/rev/f0a8263c4e28480755ddd0d1358f5a1c428b21ff

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=2d2ee0638f59a24c5e6ea43be55cc41776c9c51b&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=108302592&repo=mozilla-inbound

[task 2017-06-19T19:28:49.471126Z] 19:28:49     INFO - Entering test bound 
[task 2017-06-19T19:28:49.471997Z] 19:28:49     INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/inspector/test/doc_inspector_highlighter_xbl.xul
[task 2017-06-19T19:28:49.472661Z] 19:28:49     INFO - Tab added and finished loading
[task 2017-06-19T19:28:49.473727Z] 19:28:49     INFO - Opening the inspector
[task 2017-06-19T19:28:49.474397Z] 19:28:49     INFO - Opening the toolbox
[task 2017-06-19T19:28:49.475055Z] 19:28:49     INFO - Buffered messages logged at 19:28:48
[task 2017-06-19T19:28:49.475723Z] 19:28:49     INFO - Toolbox opened and focused
[task 2017-06-19T19:28:49.476485Z] 19:28:49     INFO - Need to wait for the inspector to update
[task 2017-06-19T19:28:49.477278Z] 19:28:49     INFO - Waiting for actor features to be detected
[task 2017-06-19T19:28:49.478088Z] 19:28:49     INFO - Check the inspector toolbar
[task 2017-06-19T19:28:49.479086Z] 19:28:49     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-eyedropper-xul.js | The button is hidden in the toolbar - 
[task 2017-06-19T19:28:49.480441Z] 19:28:49     INFO - Check the color picker
[task 2017-06-19T19:28:49.482099Z] 19:28:49     INFO - Selecting the node for '#scale'
[task 2017-06-19T19:28:49.482737Z] 19:28:49     INFO - Open the color picker
[task 2017-06-19T19:28:49.483544Z] 19:28:49     INFO - Buffered messages finished
[task 2017-06-19T19:28:49.489166Z] 19:28:49     INFO - TEST-UNEXPECTED-FAIL | devtools/client/inspector/test/browser_inspector_highlighter-eyedropper-xul.js | The button is disabled in the color picker - 
[task 2017-06-19T19:28:49.489651Z] 19:28:49     INFO - Stack trace:
[task 2017-06-19T19:28:49.490109Z] 19:28:49     INFO -     chrome://mochitests/content/browser/devtools/client/inspector/test/browser_inspector_highlighter-eyedropper-xul.js:null:35
[task 2017-06-19T19:28:49.490548Z] 19:28:49     INFO -     Tester_execTest@chrome://mochikit/content/browser-test.js:774:9
[task 2017-06-19T19:28:49.490996Z] 19:28:49     INFO -     Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:686:7
[task 2017-06-19T19:28:49.491437Z] 19:28:49     INFO -     SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
Flags: needinfo?(gl)
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/905480360832
Enable the layout view by default. r=pbro
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ef5b36e13fca
Backed out changeset 905480360832 for causing dt10 failures in browser_rules_eyedropper.js
I'll take care of this new backout.
Attachment #8878309 - Attachment is obsolete: true
Comment on attachment 8879534 [details]
Bug 1373492 - Enable the layout view by default.

https://reviewboard.mozilla.org/r/150822/#review155616

Same as previous R+'d patch, just a minor correction to the failing test.
Attachment #8879534 - Flags: review?(pbrosset) → review+
Pushed by pbrosset@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/248a1be6d550
Enable the layout view by default. r=pbro
Flags: needinfo?(gl)
https://hg.mozilla.org/mozilla-central/rev/248a1be6d550
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Depends on: 1242826
Duplicate of this bug: 1242826
Duplicate of this bug: 1373524
I have reproduced this bug with Nightly 56.0a1 (2017-06-15) (64-bit) on Ubuntu 16.04 LTS!

This bug's fix is verified with latest Nightly!


Build ID   : 20170624100118
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170621]
I have reproduced this bug with Nightly 56.0a1 (2017-06-15) on Windows 8.1 (64 bit).

This bug's fix is verified with Latest Nightly 56.0a1.

Build ID   : 20170625030210
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.