Closed Bug 137470 Opened 23 years ago Closed 22 years ago

crashes trying to install [NuBus]

Categories

(SeaMonkey :: Installer, defect)

PowerPC
Mac System 9.x
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 125411

People

(Reporter: timeless, Assigned: slogan)

References

Details

(Keywords: crash, platform-parity, relnote)

Attachments

(2 files)

7100ppc, 104mb of ram, ~100mb free space, installing from w2k appleshare
Attached file standard logs
the first time i selected custom and all items
the second time i selected just navigator and no extras
Keywords: crash
oh, this was the mozilla0.9.9 full installer
QA Contact: bugzilla → ktrina
dbradley: now i remember why your function sounded familiar, i'm pretty sure 
it's in these stacks...
->Syd
I assume this isn't happening to everyone or QA/smoketest would have caught it.
What's unique in timeless's case?
Assignee: dveditz → syd
Keywords: nsbeta1, pp
Same prefix, JS_XDR, but different functions.

Given it's blowing up in new, it's probably heap corruption. Whick unfortunately
means that stacks probably aren't going to do us much good.

Has anyone run the installer under Purify?
ok, smfr suggested off the cuff bug 138495. I think he's right.

dveditz: the unique feature is that my macs are all NuBus.
Keywords: relnote
Summary: crashes trying to install → crashes trying to install [NuBus]
This is related to bug 125411. But I'm surprised that timeless is seeing a
crash, since the fix for 125411 was to test for the presence of that symbol
before calling it.

After the Pro 7.2 conversion, I'd expect the installer to fail now because we
hard-link against SleepQInstall, and as a result, the JS DLL will fail to load.
In my experience bug 138495 is a hang (not a crash).  That bug has been resolved
for both trunk and branch.  Is this still a problem with builds from today?
Keywords: nsbeta1nsbeta1-
Bump.

I've got a NuBus Power Mac, and I'm still seeing this problem. Can't someone get 
it fixed already? I don't see how moz.org can be considering a 1.0 release when 
their code breaks on what they claim is supported hardware...
*** Bug 144191 has been marked as a duplicate of this bug. ***
*** Bug 148329 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 125411 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Verified as a dupe of bug 125411
Status: RESOLVED → VERIFIED
*** Bug 151348 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: