Closed Bug 1374784 Opened 2 years ago Closed 2 years ago

Unable to use keyboard to navigate cookies

Categories

(DevTools :: Storage Inspector, defect, P2)

53 Branch
defect

Tracking

(firefox-esr52 unaffected, firefox54 wontfix, firefox55 fixed, firefox56 verified)

RESOLVED FIXED
Firefox 56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- wontfix
firefox55 --- fixed
firefox56 --- verified

People

(Reporter: miker, Assigned: miker)

References

Details

(Keywords: regression, Whiteboard: [todo-mr][t1])

Attachments

(1 file, 1 obsolete file)

Since bug 1146194 was fixed it has not been possible to use the keyboard to navigate the cookies table.

STR:

1. Open https://addons.mozilla.org/firefox/
2. Press <shift><f9> to open the storage inspector.
3. Double-click "__utma" to enter edit mode.
4. Press <tab>.

Actual:

The cell below the edited cell is focused and the original cell is still in edit mode.

Expected:

The original edit should be closed and the cell to the right of it should be focused and enter edit mode.
358132:34fce7c12173 mratcliffe Bug 1146194 - Multiple cookies with the same name not shown r=gl
Has Regression Range: --- → yes
Has STR: --- → yes
Whiteboard: [todo-mr][t1]
Bug 1146194 landed in Firefox 53
Keywords: regression
Comment on attachment 8879921 [details]
Bug 1374784 - Unable to use keyboard to navigate cookies

https://reviewboard.mozilla.org/r/151316/#review156450
Attachment #8879921 - Flags: review?(gl) → review+
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ea5a5610ff7e
Unable to use keyboard to navigate cookies r=gl
https://hg.mozilla.org/mozilla-central/rev/ea5a5610ff7e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Not a new regression, fix-optional for 55, though feel free to request uplift after this is verified in nightly.
Version: 51 Branch → 53 Branch
I have reproduced this bug with Nightly 56.0a1 (2017-06-20) (64-bit) on Ubuntu 16.04 LTS!

This bug's fix is verified with latest Nightly!

Build ID   : 20170623115718
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170621]
I have reproduced this Bug on Nightly 56.0a1 (2017-06-20) on Windows 10, 64 Bit!

The bug's fix is now verified on latest Nightly

Build ID 	20170623045418
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

[bugday-20170621]
sorry hat to back this out in https://treeherder.mozilla.org/logviewer.html#?job_id=109864699&repo=mozilla-central since somehow this test is now a perma failure. Mike can you take a look ?
Status: RESOLVED → REOPENED
Flags: needinfo?(mratcliffe)
Resolution: FIXED → ---
Backout by cbook@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/da4ac701aae7
Backed out changeset ea5a5610ff7e for getting perma failures are merge
See Also: → 1376281
Attachment #8879921 - Attachment is obsolete: true
Flags: needinfo?(mratcliffe)
Attachment #8881485 - Flags: review?(gl) → review+
Attachment #8881485 - Flags: review+ → review?(mratcliffe)
Comment on attachment 8881485 [details]
Bug 1374784 - Unable to use keyboard to navigate cookies

https://reviewboard.mozilla.org/r/151314/#review157992

This patch bounced previously but is completely green on try wouthout any changes.
Comment on attachment 8881485 [details]
Bug 1374784 - Unable to use keyboard to navigate cookies

https://reviewboard.mozilla.org/r/152624/#review157994
Attachment #8881485 - Flags: review?(mratcliffe) → review+
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/16ae2d86aae4
Unable to use keyboard to navigate cookies r=miker
https://hg.mozilla.org/mozilla-central/rev/16ae2d86aae4
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Did you want to consider uplifting this to Beta so DevEdition users get the fix before next month?
Flags: needinfo?(mratcliffe)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #17)
> Did you want to consider uplifting this to Beta so DevEdition users get the
> fix before next month?

Great point, yes, I would like to request uplift but don't see the UI to do so... I assume I need to use the tracking section?

[Tracking Requested - why for this release]:
Fixes keyboard navigation in the storage inspector... this is needed for accessibility.
Flags: needinfo?(mratcliffe)
Comment on attachment 8881485 [details]
Bug 1374784 - Unable to use keyboard to navigate cookies

Approval Request Comment
[Feature/Bug causing the regression]: Storage inspector rewrite
[User impact if declined]: Storage Inspector will not be usable for keyboard users (accessibility issue).
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: It is a fairly simple change
[String changes made/needed]: None
Attachment #8881485 - Flags: approval-mozilla-beta?
Comment on attachment 8881485 [details]
Bug 1374784 - Unable to use keyboard to navigate cookies

devtools fix, beta55+

should be in 55.0b9
Attachment #8881485 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #19)
> [Is this code covered by automated tests?]: yes
> [Has the fix been verified in Nightly?]: yes
> [Needs manual test from QE? If yes, steps to reproduce]: No

Setting qe-verify- based on Michael's assessment on manual testing needs and the fact that this fix has automated coverage.
Flags: qe-verify-
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.