Have to kill Nightly from Task Manager to update

RESOLVED DUPLICATE of bug 1375242

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 1375242
5 months ago
4 months ago

People

(Reporter: Mahesh Asolkar, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170621102301

Steps to reproduce:

Use the 'About Nightly' dialog to check for update. If available, click the button to install update.

-----
Name: Firefox
Version: 56.0a1
Build ID: 20170621102301
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
OS: Windows_NT 10.0
Multiprocess Windows: 1/1 (Enabled by default)
Google Key: Found
Mozilla Location Service Key: Found
Safe Mode: false
-----


Actual results:

Clicking on the update button did not install the update; Nightly did closed, but did not restart automatically.

Upon inspecting 'Task Manager', discovered that there is a 'Nightly' process still running. Task manager's 'End Task' had to be used to kill the Nightly process.

If 'Task Manager' was inspected right after clicking on update button, one or more processes of Nightly and one process of updater were seen. If Nightly process is killed while updater process is still running, the update happens and Nightly launches automatically after the update is installed. This is the workaround I am using at the moment.

I've noticed this behavior for a few weeks now.



Expected results:

Normally, when update button is clicked, Nightly should close, Nightly should be updated, updated Nightly should launch automatically.

Updated

5 months ago
Component: Untriaged → Application Update
Product: Firefox → Toolkit
Depends on: 1375242
I've changed the updater in Bug 1375549 so it will apply the update anyways so if there is a fix for the Firefox (other applications as well) process not exiting the client will get the fix and to not try to launch Firefox (other applications as well) when the process hasn't exited. This should merge into Nightly in a couple of days.

The issue with Firefox (other applications as well) will need to be fixed in Bug 1375242 so I am duplicating this bug to that bug. The developers working on bug 1375242 need additional information per bug 1375242 comment #2 so if you can help provide that information it would be helpful. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1375242
I didn't managed to reproduce the issue with the stated build in comment 0 (Firefox 56.0a1 from 2017-06-21).

I managed to reproduce this issue with Firefox 56.0a1 from 2017-06-28 (as stated in bug 1377441) but the actual result is slightly different:

Same results with reporter:
Firefox Nightly doesn't automatically restarts after update.

Different result:
The Nightly processes are killed and are no longer visible in task manager.

Note: 
This issue is not reproducible while updating Firefox Nightly from 2017-07-15 to the current version
(In reply to Emil Ghitta, QA [:emilghitta] from comment #2)
> I didn't managed to reproduce the issue with the stated build in comment 0
> (Firefox 56.0a1 from 2017-06-21).
> 
> I managed to reproduce this issue with Firefox 56.0a1 from 2017-06-28 (as
> stated in bug 1377441) but the actual result is slightly different:
> 
> Same results with reporter:
> Firefox Nightly doesn't automatically restarts after update.
> 
> Different result:
> The Nightly processes are killed and are no longer visible in task manager.
> 
> Note: 
> This issue is not reproducible while updating Firefox Nightly from
> 2017-07-15 to the current version
What you experienced was bug 1376612 which is a regression and has a different cause than what the reporter experienced.
Based on comment 3, I am failing to reproduce this.

Mahesh, can you still reproduce this with a more recent nightly ? (ex: Nightly from 2017-07-15).

Thanks!
Flags: needinfo?(asolkar)
(Reporter)

Comment 5

4 months ago
(In reply to Emil Ghitta, QA [:emilghitta] from comment #4)
> Based on comment 3, I am failing to reproduce this.
> 
> Mahesh, can you still reproduce this with a more recent nightly ? (ex:
> Nightly from 2017-07-15).
> 
> Thanks!

Just tried Nightly update, it went as expected. I did not have to kill nightly process. Seems like the bug is fixed.
Flags: needinfo?(asolkar)
You need to log in before you can comment on or make changes to this bug.