Closed Bug 1376612 Opened 4 years ago Closed 4 years ago

Relaunch callback app even when the pid is still present.

Categories

(Toolkit :: Application Update, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Bug 1375549 made it so the callback application isn't relaunched when the pid is still present. A couple of people have seen Firefox not relaunch even when the pid has exited. Since the end result of relaunching when the pid hasn't exited is no worse than not relaunching just go ahead and try to relaunch.
Attached patch patch rev1 (obsolete) — Splinter Review
I will update the test in a separate patch
Attached patch patchSplinter Review
Attachment #8881580 - Attachment is obsolete: true
Attachment #8881813 - Flags: review?(mhowell)
Comment on attachment 8881813 [details] [diff] [review]
patch

Review of attachment 8881813 [details] [diff] [review]:
-----------------------------------------------------------------

r+ pending try run.
Attachment #8881813 - Flags: review?(mhowell) → review+
Duplicate of this bug: 1376876
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/43c421b4a763
Relaunch callback app even when the pid is still present. r=mhowell
Duplicate of this bug: 1377095
https://hg.mozilla.org/mozilla-central/rev/43c421b4a763
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Fixed? Updating from yesterday build to today as always failed. I had to manually kill firefox processes.
Yes, patch landed, so it's fixed, as you can see in "Status", updating next Nightly (2017-06-30) to (2017-07-01) should work fine.
(In reply to tkdubiel from comment #9)
> Fixed? Updating from yesterday build to today as always failed. I had to
> manually kill firefox processes.
What do you think this patch does?
Flags: needinfo?(tkdubiel)
Nevermind, replying in bug 1375549.
Flags: needinfo?(tkdubiel)
Duplicate of this bug: 1377103
Duplicate of this bug: 1377441
Flags: in-testsuite+
Resolved in nightly 56.0a1 07/03/2017 build.
Thanks!
You need to log in before you can comment on or make changes to this bug.