[Fennec][HLS] Issues with videos from twitch.tv

NEW
Unassigned

Status

()

Firefox for Android
Audio/Video
P3
normal
5 months ago
3 months ago

People

(Reporter: sorina, Unassigned)

Tracking

(Blocks: 1 bug)

56 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox56 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
Environment: 
Device: Asus ZenPad 8 (Android 6.0.1), Honor 8 (Android 6.0);
Build: Nightly 56.0a1 (2017-07-03);

Steps to reproduce:
1. Launch Fennec and go to about:config and change media.mediasource.enabled to false; 
2. Go to twitch.tv and play a video; 

Expected result:
The video is playing and no interruptions or glitches are triggered.

Actual result:
The video is loading and no video is played.

Notes:
Before pressing the play button a message is displayed: "this site uses a plugin that may slow Nightly".

Comment 1

5 months ago
Hi Sorina,

I've tested this on Nexus 5 (A factory reset to Android 5.0), cannot reproduce it.
This message "this site uses a plugin that may slow Nightly" comes from [1] and a plugin is used to play the video.

[1] http://searchfox.org/mozilla-central/rev/a3a739de04ee6134c11546568a33dbb6a6a29907/browser/base/content/browser-plugins.js#393


Could you please snapshot about:plugins for more information ? Thanks !
Flags: needinfo?(sorina.florean)
(Reporter)

Comment 2

5 months ago
Created attachment 8883228 [details]
Screenshot_2017-07-04-11-01-30.png

Tested again with Nexus 5 (Android 6.0.1) and the issue is not reproducible. But on Huawei Honor (Android 5.1.1) I've got a black video for 1 min and only after that I could see the video. 
And with Asus Zenpad 8 (Android 6.0.1) the behavior is the same as in description, still loading. It was the same video an all devices.
Flags: needinfo?(sorina.florean)
This issue cannot be reproduced by Google Pixel Android 7.1.2 by Nightly.

We will try to find a device that can reproduce this symptom.

Fortunately, this website uses MSE as its first priority.

Hi Sorina,

Few questions need your help to clarify,

As your description on comment 2,

Did you test the website by latest nightly, and those devices can play HLS content with another website, right?

Huawei Honor (Android 5.1.1) can play this video only if you wait for precisely 1 minute?

Asus Zenpad 8 (Android 6.0.1) cannot play this video permanently right?

Was the attachment you provided captured by the Zenpad 8 or Huawei Honor?

Thank you for reporting this, let us find a device and investigate deeper.
Flags: needinfo?(sorina.florean)
Set this bug as p3 since normally user would not disable media source on purpose.
Priority: -- → P3
(Reporter)

Comment 5

5 months ago
Sorry for late replay, see my answers in line.

(In reply to James Cheng[:JamesCheng] from comment #3)
> This issue cannot be reproduced by Google Pixel Android 7.1.2 by Nightly.
> 
> We will try to find a device that can reproduce this symptom.
> 
> Fortunately, this website uses MSE as its first priority.
> 
> Hi Sorina,
> 
> Few questions need your help to clarify,
> 
> As your description on comment 2,
> 
> Did you test the website by latest nightly, and those devices can play HLS
> content with another website, right?
Yes, build was latest Nightly and other HlS video is working as expected.
> Huawei Honor (Android 5.1.1) can play this video only if you wait for
> precisely 1 minute?
Not precisely, I was able to play the video but with build from today (7/7) I can't. It's the same behavior as on Asus.  
> Asus Zenpad 8 (Android 6.0.1) cannot play this video permanently right?
I tried again to play the video and left open the page for almost 30 min and the video is still loading.
> Was the attachment you provided captured by the Zenpad 8 or Huawei Honor?
The attachment was captured with the Huawei Honor. Here is for Asus: https://i.imgur.com/Vbo05c4.png.
> Thank you for reporting this, let us find a device and investigate deeper.
Flags: needinfo?(sorina.florean)

Comment 6

4 months ago
Regarding the keep loading issue, I found that the tracks information is not notified from ExoPlayer, that resulted to a pending status for HLSDemuxer.

Investigating.

Comment 7

4 months ago
Once Bug 1381916 landed, there's no flash plugin on Fennec, I would take some time look back here.
ni ? myself.
Flags: needinfo?(kikuo)

Comment 8

3 months ago
Drop the ni ? as we're not shipping this feather  soon.
Flags: needinfo?(kikuo)
You need to log in before you can comment on or make changes to this bug.