Status

enhancement
P3
normal
RESOLVED FIXED
2 years ago
7 months ago

People

(Reporter: Honza, Assigned: bgrins)

Tracking

(Blocks 1 bug, {dev-doc-complete})

unspecified
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(3 attachments)

Firebug theme landed in devtools primarily to help with Firebug -> DevTools transition. 

Since all add-ons has been deprecated (since Firefox 57) and replaced by WebExtensions, it isn't possible to install Firebug at all and thus there is no transition path. The additional (transition) UI we introduced in Firebug isn't available anymore.

Also, the Firebug theme was introduced for Firefox Australis theme (~2012) and might feel a bit old these days. It's probably good time to remove the theme entirely.

Honza
As discussed last week, and in a meeting this week, I agree with this. Once we start shipping a new, Photon-compatible, design, I don't think we should be maintaining the Firebug theme anymore.
We might take this on during Q3, within the Perf & Polish project that Mike and Gabriel are working on (CC'ing them now).
Priority: -- → P3
Before rushing into this, we implemented a new probe to gather actual data (bug 1396811).
Here's data from this probe in Nightly 58: https://telemetry.mozilla.org/new-pipeline/dist.html#!cumulative=1&end_date=2017-09-27&keys=LIGHT!DARK!FIREBUG!__none__&max_channel_version=nightly%252F58&measure=SCALARS_DEVTOOLS.CURRENT_THEME&min_channel_version=null&processType=*&product=Firefox&sanitize=1&sort_keys=submissions&start_date=2017-09-21&table=0&trim=1&use_submission_date=0

The numbers are: 18.5k light theme, 8.2k dark theme, 375 Firebug. This means 1.4% for Firebug only.
Now, we need to wait until we get numbers on release 56 too, only there will we know what our users actually use and what the ratio of Firebug theme users is.

But so far, the numbers are telling us that the amount of time we spend maintaining the Firebug theme is probably not worth it.
Recently, a lot of time was put in bug 1389730 to refresh our light and dark themes. Doing this in a way that the Firebug theme still worked proved very difficult. So this theme has an important maintenance cost.
We now have more numbers on release 56.
I created a spreadsheet with the data I found relevant in it: https://docs.google.com/spreadsheets/d/1haDZMiHpYRbwGR2mgvVmUlCOUZFmGLwN90KE4ARXbzI/edit#gid=0
This is now actionable, so marking as good-first-bug.

https://github.com/devtools-html/rfcs/issues/42
Keywords: good-first-bug
I don't think this is ready to marked as a good first bug, at least pending a decision on what the migration plan will be.
Keywords: good-first-bug
By the way, I have a WIP patch that removes most of the rules at https://github.com/devtools-html/rfcs/issues/42#issuecomment-369675504. It could be landed separately to begin simplifying our CSS, or could be modified to remove the theme entirely.
(In reply to Brian Grinstead [:bgrins] from comment #5)
> I don't think this is ready to marked as a good first bug, at least pending
> a decision on what the migration plan will be.
I have captured the product requirements in this PRD: https://docs.google.com/document/d/1BjXRV8OwWf7V2Km6UPDNpcVBdvXcGaOO7rCVFAJzmiE/edit and got it reviewed by Harald, who agrees we do not require a migration plan.
Harald: can you provide a confirmation here please, so we can go ahead with this bug?
Flags: needinfo?(hkirschner)
The doc is private.
(In reply to Tim Nguyen :ntim from comment #9)
> The doc is private.

Made available.

> Harald: can you provide a confirmation here please, so we can go ahead with this bug?

Green light from me.
Flags: needinfo?(hkirschner)
Comment on attachment 8964312 [details]
Bug 1378108 - Part 1 - Remove non-variable css selector overrides for Firebug theme;

https://reviewboard.mozilla.org/r/233034/#review239412

::: devtools/client/shared/components/tabs/Tabs.css:81
(Diff revision 3)
>    position: relative;
>    border-bottom: 1px solid var(--theme-splitter-color);
>    background: var(--theme-tab-toolbar-background);
>  }
>  
>  .theme-dark .tabs .tabs-menu-item,

Maybe unrelated and can be done seperately in another bug or patch, but it seems like we can remove theme-dark/light from these selectors since they were there to guard against applying the rules for the firebug theme.

::: devtools/client/shared/components/tree/TreeView.css:184
(Diff revision 3)
>  /******************************************************************************/
>  /* Themes */
>  
>  /* :not(.selected) is used because row selection styles should have
>     more precedence than row hovering. */
>  .theme-light .treeTable .treeRow:not(.selected):hover,

Same as above.
Attachment #8964312 - Flags: review?(gl) → review+
Comment on attachment 8964994 [details]
Bug 1378108 - Part 2 - Remove Firebug theme;

https://reviewboard.mozilla.org/r/233740/#review239420
Attachment #8964994 - Flags: review?(gl) → review+
Comment on attachment 8964995 [details]
Bug 1378108 - Part 3 - Migrate Firebug theme users to the light theme;

https://reviewboard.mozilla.org/r/233742/#review239490
Attachment #8964995 - Flags: review?(gijskruitbosch+bugs) → review+
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/058d1b523272
Part 1 - Remove non-variable css selector overrides for Firebug theme;r=gl
https://hg.mozilla.org/integration/autoland/rev/77eaf99d1363
Part 2 - Remove Firebug theme;r=gl
https://hg.mozilla.org/integration/autoland/rev/311320b0570a
Part 3 - Migrate Firebug theme users to the light theme;r=Gijs
I have reproduced this bug with Nightly 56.0a1 (2017-07-05) on Ubuntu 16.04 LTS!

This bug's fix is Verified with latest Nightly !

Build   ID - 20180424220100
User Agent - Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
QA Whiteboard: [bugday-20180425]
Product: Firefox → DevTools
Removed the reference to the Firebug theme from the page and replaced the image of Developer Tools Settings so that it no longer lists the Firebug theme as a choice.
Depends on: 1492008
Blocks: 1519791
You need to log in before you can comment on or make changes to this bug.