Minimize/maximize/close buttons are not visible with Light Themes/Appearances/Personas

VERIFIED FIXED in Firefox 56

Status

()

defect
--
major
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: VladB, Assigned: dvander)

Tracking

({regression, reproducible})

56 Branch
mozilla56
x86_64
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 verified)

Details

(Whiteboard: [gfx-noted] [fixed by patch from bug #1378095])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170703030203

[Affected versions]:
- Firefox nightly 56.0a1

[Affected Platforms]:
- Windows 8.1

[Prerequisites]:
- Firefox Nightly browser is maximized.

[Steps to reproduce]:
1. Click on "Hamburger Menu" button.
2. Click on "Customize..." button.
3. From Themes select Compact Dark or Compact Light.
4. Click on "Done" button.

[Expected result]:
- Theme is successfully changed and browser window buttons are displayed.

[Actual result]:
- After the theme is changed with one from the compact ones, the browser window buttons are no longer displayed. If the user clicks on an area where the buttons should be, the action is made for the button that supposed to be displayed in that area.

[Notes]:
- Attached a screenshot of the issue.
(Reporter)

Comment 1

2 years ago
I did a regression range and this is the log:

INFO: Narrowed inbound regression window from [3dac0535, bc2343d4] (3 revisions) to [3dac0535, 684b6b32] (2 revisions) (~1 steps left)
INFO: No more inbound revisions, bisection finished.
INFO: Last good revision: 3dac05357e713c8f15a5e2561e2ed22a10c7ebc8
INFO: First bad revision: 684b6b32fab2c5a88f4b2ae397a36a007bd8cb39
INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3dac05357e713c8f15a5e2561e2ed22a10c7ebc8&tochange=684b6b32fab2c5a88f4b2ae397a36a007bd8cb39

It seems that Bug 1375743 has caused this. @David, can you take a look at this?
Flags: needinfo?(dvander)
I can't reproduce this - can you attach your about:support?
Flags: needinfo?(dvander) → needinfo?(vlad.bacia)
(Reporter)

Comment 3

2 years ago
Apparently this issue is no longer reproducible with latest Nightly (Build ID: 20170704030203).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(vlad.bacia)
Resolution: --- → FIXED

Updated

2 years ago
Resolution: FIXED → WORKSFORME

Updated

2 years ago
Component: Themes → Graphics
Product: Toolkit → Core
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1377866
(In reply to Vlad Bacia-Mociran [:VladB], Desktop Engineering QA from comment #3)
> Apparently this issue is no longer reproducible with latest Nightly (Build
> ID: 20170704030203).

Well, bug 1375743 got backed out.
Component: Graphics → Themes
Product: Core → Toolkit
Resolution: DUPLICATE → WORKSFORME
You can re-test by setting layers.mlgpu.dev-enabled = true. We're going to re-enable bug 1375743 soon though, so please re-open if it still happens after.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

2 years ago
Duplicate of this bug: 1377844
I can reproduce this issue on Windows 7.
Blocks: 1379731
Severity: normal → major
Status: REOPENED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Themes → Graphics: Layers
Product: Toolkit → Core
Version: Trunk → 56 Branch
minimize/maximize/close buttons with Default theme are hazy
minimize/maximize/close buttons with other Light/Appearance/Persona theme are not visible
OS: Windows 8.1 → Windows
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #8)
> I can reproduce this issue on Windows 7.

Advanced Layers isn't enabled on Windows 7 - did you force it on via about:config?
Flags: needinfo?(Virtual)
Yes.
I enabled it by myself by setting to "true" these 2 preferences: "layers.mlgpu.dev-enabled" & "layers.mlgpu.enable-on-windows7", it was to see if it's fixed yet, per re-enabling Advanced Layers in Nightly on Windows 8+ and to see if it's also reproducible on Windows 7.

I'm attaching Graphics section from about:support.
Flags: needinfo?(Virtual)
Summary: Firefox Nightly window buttons are missing while using compact themes (Dark or Light) → Minimize/maximize/close buttons are not visible with Light Themes/Appearances/Personas

Updated

2 years ago
Whiteboard: [gfx-noted]
Does this reproduce on Windows 10 or only 7 and 8.1?
I can reproduce it on Windows 7,
but looking on dupe and on OP post, it is or was reproducible also on Windows 8.1.

Comment 14

2 years ago
It is reproducible on Windows 8.1 for me at the moment.
I'm unable to reproduce this on like four different computers. Could anyone take a full window screenshot or video of what happens?

Comment 16

2 years ago
Posted image 1378111.png
Thanks, that is more clear - I was able to reproduce this on Windows 8.1. It seems to be fixed by bug 1378095, but I'll leave this open so folks can confirm after that lands.

Updated

2 years ago
Duplicate of this bug: 1380478

Comment 19

2 years ago
It has been fixed for me on latest Nightly 20170713030205 (Windows 8.1).
Flags: needinfo?(Virtual)
(Reporter)

Comment 20

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170713030205

I can reproduce this issue on Windows 8.1.

Comment 21

2 years ago
I'm sorry for my mistake. 
For some reason layers.mlgpu.sanity-test-failed set to 'true' (but before 20170713030205 this has been 'false').
It's fixed starting with Mozilla Firefox Nightly 56.0a1 (2017-07-14).
Status: NEW → RESOLVED
Last Resolved: 2 years ago2 years ago
Depends on: 1378095
Flags: needinfo?(Virtual)
Resolution: --- → FIXED
Whiteboard: [gfx-noted] → [gfx-noted] [fixed by patch from bug #1378095]
Assignee: nobody → dvander
Target Milestone: --- → mozilla56
QA Whiteboard: [good first verify]
I have successfully reproduced this bug with Nightly 56.0a1 (2017-07-04) (32-bit) on windows 10(32bit)

this bug is verified fix with  latest beta 58.0b4 (32-bit)
Build ID: 20171115114231
Mozilla/5.0 (Windows NT 10.0; rv:58.0) Gecko/20100101 Firefox/58.0
QA Whiteboard: [good first verify] → [good first verify][testday-20171117]
I also can confirm that the issue is verified fixed on 56.0.2 build1 (20171024165158) (and that 57.0 and 58.0b4 builds are not affected) using Windows 8.1 x64. 
Thank you Md. Rahimul Islam for your testing efforts!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.