Application window top border edge missing on Windows 10

RESOLVED FIXED in Firefox 56

Status

()

--
trivial
RESOLVED FIXED
a year ago
15 days ago

People

(Reporter: ke5trel, Assigned: dvander)

Tracking

56 Branch
mozilla56
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

a year ago
Created attachment 8883261 [details]
win10-missing-top-border.png

The Photon mockups show that the application window should have a native top border edge accent color but the current Nightly does not have one.
(Reporter)

Updated

a year ago
Whiteboard: [photon-visual]
Whiteboard: [photon-visual] → [photon-visual] [triage]

Updated

a year ago
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

a year ago
See Also: → bug 1378097
(Reporter)

Comment 1

a year ago
Can no longer reproduce in today's 2017-07-04 build. No bug was fixed for it specifically. Can anyone confirm?

Comment 2

a year ago
Yes, no longer reproduce in today's 2017-07-04 build.

per https://developer.mozilla.org/en-US/docs/Mozilla/Bugzilla/What_to_do_and_what_not_to_do_in_Bugzilla#Resolving_bugs_as_WORKSFORME
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Whiteboard: [photon-visual] [triage]
(Reporter)

Comment 3

a year ago
It disappeared again on today's 2017-07-11 build.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: [photon-visual] [triage]
(Reporter)

Comment 4

a year ago
Regressed by Bug 1375743. Fixed by setting layers.mlgpu.dev-enabled = false.
Blocks: 1375743

Comment 5

a year ago
Ni per comment #4 - dvander, could you take a look?
Flags: needinfo?(dvander)
Thanks, I can reproduce this. It looks like AL is failing to force a clear of the non-client area, which the old compositor does. This should be easy to fix.
Assignee: nobody → dvander
Status: REOPENED → ASSIGNED
Flags: needinfo?(dvander)
Created attachment 8885609 [details] [diff] [review]
part 1, helper for ClearView

We have two different regions to clear: the area not covered by opaque pixels, and the area that must be clear after rendering is finished.

This patch refactors the clear code in RenderViewMLGPU so it can be re-used for separate draw calls. The only reason this code exists to begin with is so we can use ClearView if it's available, since it's much faster. And unfortunately the inputs to ClearView are totally different versus the clear shader.
Attachment #8885609 - Flags: review?(matt.woodrow)
Created attachment 8885611 [details] [diff] [review]
part 2, fix bug

This renames the existing clear operation to a "pre-clear" and the new clear operation is a "post-clear". The post-clear region is clamped to the invalid area, and is added to the initial opaque area.
Attachment #8885611 - Flags: review?(matt.woodrow)
Component: Theme → Graphics: Layers
Product: Firefox → Core
Whiteboard: [photon-visual] [triage]
Attachment #8885609 - Flags: review?(matt.woodrow) → review+
Attachment #8885611 - Flags: review?(matt.woodrow) → review+

Comment 9

a year ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/59d05f6cda7a
Add a helper for automating ClearView and clear-shader operations. (bug 1378095 part 1, r=mattwoodrow)
https://hg.mozilla.org/integration/mozilla-inbound/rev/cec67bb0c301
Fix Advanced Layers not forcing a clear for the window theme. (bug 1378095 part 2, r=mattwoodrow)

Comment 10

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/59d05f6cda7a
https://hg.mozilla.org/mozilla-central/rev/cec67bb0c301
Status: ASSIGNED → RESOLVED
Last Resolved: a year agoa year ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Depends on: 1380830

Updated

15 days ago
No longer depends on: 1380830
You need to log in before you can comment on or make changes to this bug.