Closed Bug 1378421 Opened 3 years ago Closed 3 years ago

Prompt user to install PWA

Categories

(Firefox for Android :: Web Apps (PWAs), enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1393672

People

(Reporter: snorp, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [pwa-front-end])

There is a lot of consideration here around how/when/if we prompt and what the criteria should be. Google has their guidelines published here: https://developers.google.com/web/progressive-web-apps/checklist
Andreas mentioned to me that we probably want badging and not prompting, as https://dev.opera.com/blog/pwa-badge-pop/
See Also: → 1379115
Spec: https://www.w3.org/TR/appmanifest/#installation-events

Relevant note: as was announced at Google IO, Chrome will soon no longer have an engagement requirement to show an install prompt. There will still be a number of technical requirements (https, manifest, etc.), but it will be possible to trigger the install prompt via a user gesture (e.g. a button on a web page) without having to wait for a certain level of user engagement.
Flags: needinfo?(cnevinchen)
Flags: needinfo?(cnevinchen)
Whiteboard: [pwa-front-end]
Priority: -- → P2
Not doing this for now.
Priority: P2 → P3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1393672
You need to log in before you can comment on or make changes to this bug.