Show a badge (in the position of a page action) when a website is installable as a PWA

RESOLVED DUPLICATE of bug 1393672

Status

()

Firefox for Android
General
P1
normal
RESOLVED DUPLICATE of bug 1393672
10 months ago
6 months ago

People

(Reporter: abovens, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FNC][SPT58.3][MVP][pwa-front-end])

(Reporter)

Description

10 months ago
As per the all-hands discussion about PWA support, we should look into adding a badge (in the address field, perhaps) that appears when certain conditions indicating installability are met. E.g. presence of all of the following:
- HTTPS
- manifest
- name or short_name in the manifest
- an icon of a certain size
- a service worker (?)
- ...
should show an icon indicating installability. 

Note: this is different from an "install banner" overlay, which can be perceived as more intrusive.

Updated

8 months ago
Flags: needinfo?(cnevinchen)

Updated

8 months ago
Flags: needinfo?(cnevinchen)
Whiteboard: [pwa-front-end]
Priority: -- → P1

Updated

8 months ago
Summary: Show a badge when a website is installable as a PWA → Show a page acion when a website is installable as a PWA
(Reporter)

Comment 1

8 months ago
Sorry, why was this renamed? "Badge" is the typical term here. "Page action" refers to extension APIs. Let's not conflate the two.
(Reporter)

Updated

7 months ago
Summary: Show a page acion when a website is installable as a PWA → Show a badge (in the position of a page action) when a website is installable as a PWA

Updated

6 months ago
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1393672
Whiteboard: [pwa-front-end] → [FNC][SPT58.3][MVP][pwa-front-end]
You need to log in before you can comment on or make changes to this bug.