add `mach cargo check` command

RESOLVED FIXED in Firefox 56

Status

()

Core
Build Config
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: froydnj, Assigned: froydnj)

Tracking

unspecified
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(2 attachments)

No reason Gecko developers shouldn't have this.
Created attachment 8883632 [details] [diff] [review]
part 1 - make Cargo invocation macro more generic

All the machinery we set up for `cargo build` is equally useful for
other commands, such as `cargo check`.  Let's refactor things so that
it's easy to reuse said machinery for `cargo check`.
Attachment #8883632 - Flags: review?(giles)
Created attachment 8883633 [details] [diff] [review]
part 2 - add `mach cargo check`

Cargo recently introduced the `cargo check` command for shortening the
edit-compile cycle when working on large programs.  Since we don't
really support invoking `cargo` directly, let's wire up this command to
`mach`.  Gecko developers can then `mach cargo check` to ensure their
changes typecheck.

I'm not completely happy with the rules.mk changes, but they were the easiest
way I could think of doing things, since I didn't want to store information on
what *kind* of crate we had at the mach level.  I just wanted to say "check",
and let the Makefile sort out what needs doing.  Let me know what you think.
Attachment #8883633 - Flags: review?(giles)
Comment on attachment 8883633 [details] [diff] [review]
part 2 - add `mach cargo check`

Review of attachment 8883633 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thanks for doing this!
Attachment #8883633 - Flags: review?(giles) → review+
Attachment #8883632 - Flags: review?(giles) → review+

Comment 4

5 months ago
Pushed by nfroyd@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4168fad05a11
part 1 - make Cargo invocation macro more generic; r=rillian
https://hg.mozilla.org/integration/mozilla-inbound/rev/90323301d1b1
part 2 - add `mach cargo check`; r=rillian

Comment 5

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4168fad05a11
https://hg.mozilla.org/mozilla-central/rev/90323301d1b1
Status: NEW → RESOLVED
Last Resolved: 5 months ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Duplicate of this bug: 1354401
You need to log in before you can comment on or make changes to this bug.